Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] No "start" attribute in Content-Type: trouble with WASP and MIME

Expand Messages
  • Byrne Reese
    I assume you are using SOAP::Lite 0.66.1. I would also contact Amazon - as the W3C SOAP with Attachment specification strongly recommends that the start
    Message 1 of 3 , Jan 6, 2006
    • 0 Attachment
      I assume you are using SOAP::Lite 0.66.1.

      I would also contact Amazon - as the W3C SOAP with Attachment
      specification strongly recommends that the start parameter be present.

      http://www.w3.org/TR/SOAP-attachments
      It is strongly recommended that the root part contain a |Content-ID|
      MIME header structured in accordance with RFC 2045
      <http://www.w3.org/TR/2000/NOTE-SOAP-attachments-20001211#MIME1>, and
      that in addition to the required parameters for the |Multipart/Related|
      media type, the start parameter (optional in RFC 2387
      <http://www.w3.org/TR/2000/NOTE-SOAP-attachments-20001211#MultipartRelated>)
      always be present. This permits more robust error detection.

      But since technically it is not required, let me take a look.

      Nate wrote:
      > I am working with Amazons (WASP, I believe) server to download MIME
      > attachments. The problem is WASP doesn't send the optional 'start'
      > attribute in the Content-Type header. This causes SOAP::Lite to die.
      > Obviously I could handle the fault so it wouldnt die, but I still
      > would not be able to parse the MIME.
      >
      > I guess I could override the method and do my own MIME parsing (bluhk,
      > I'd rather not...)
      >
      > Anyone have any suggestions?
      >
      > -Nate Murray
      >
      >
      >
      >
      >
      > ------------------------------------------------------------------------
      > YAHOO! GROUPS LINKS
      >
      > * Visit your group "soaplite
      > <http://groups.yahoo.com/group/soaplite>" on the web.
      >
      > * To unsubscribe from this group, send an email to:
      > soaplite-unsubscribe@yahoogroups.com
      > <mailto:soaplite-unsubscribe@yahoogroups.com?subject=Unsubscribe>
      >
      > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
      > Service <http://docs.yahoo.com/info/terms/>.
      >
      >
      > ------------------------------------------------------------------------
      >
    • Byrne Reese
      Weird - it should behave correctly with 0.66+. Here is the code from the Packager: die Multipart MIME messages MUST declare Multipart/Related content-type if
      Message 2 of 3 , Jan 6, 2006
      • 0 Attachment
        Weird - it should behave correctly with 0.66+. Here is the code from the
        Packager:

        die "Multipart MIME messages MUST declare Multipart/Related content-type"
        if ($entity->head->mime_attr('content-type') !~ /^multipart\/related/i);
        my $start =
        get_multipart_id($entity->head->mime_attr('content-type.start'))
        || get_multipart_id($entity->parts(0)->head->mime_attr('content-id'));
        my $location = $entity->head->mime_attr('content-location') ||
        'thismessage:/';

        As you can see - it first looks for the start parameter and if it cannot
        be found it simply grabs the content id of the root part... do you have
        code I can use to reproduce the problem?

        Nate wrote:
        > I am working with Amazons (WASP, I believe) server to download MIME
        > attachments. The problem is WASP doesn't send the optional 'start'
        > attribute in the Content-Type header. This causes SOAP::Lite to die.
        > Obviously I could handle the fault so it wouldnt die, but I still
        > would not be able to parse the MIME.
        >
        > I guess I could override the method and do my own MIME parsing (bluhk,
        > I'd rather not...)
        >
        > Anyone have any suggestions?
        >
        > -Nate Murray
        >
        >
        >
        >
        >
        > ------------------------------------------------------------------------
        > YAHOO! GROUPS LINKS
        >
        > * Visit your group "soaplite
        > <http://groups.yahoo.com/group/soaplite>" on the web.
        >
        > * To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        > <mailto:soaplite-unsubscribe@yahoogroups.com?subject=Unsubscribe>
        >
        > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service <http://docs.yahoo.com/info/terms/>.
        >
        >
        > ------------------------------------------------------------------------
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.