Loading ...
Sorry, an error occurred while loading the content.

use_prefix has been deprecated warning

Expand Messages
  • amla2216
    Hello, I have a problem when upgrading to Soap::Lite 0.66 I have a simple code which worked in previous version (I replaced uri by ns (using default_ns instead
    Message 1 of 2 , Jan 3, 2006
    • 0 Attachment
      Hello,

      I have a problem when upgrading to Soap::Lite 0.66

      I have a simple code which worked in previous version (I replaced uri
      by ns (using default_ns instead of ns doesn't solve the problem)).

      use SOAP::Lite + autodispatch => ns => 'FilterList', proxy =>
      'tcp://localhost:4444';
      my $f = FilterList->new();
      $f->add_new_filter('Filtre 1');

      this code now generates several warnings on both client and server
      side "use_prefix has been deprecated. if you wish to turn off or on
      the use of a default namespace, then please use either ns(uri) or
      default_ns(uri) at /usr/lib/perl5/site_perl/5.8.6/SOAP/Lite.pm line 858."

      but the worse is that the second method (add_new_filter from my
      example is never called, (it was in the previous version of SOAP::Lite)

      I'm new to SOAP::Lite and I really don't see how to make this simple
      peace of code work in the new version.

      Any help would be gretely apprecaited.

      Michael
    • Byrne Reese
      Haven t heard about this in a while - did this ever get resolved for everyone with the latest releases?
      Message 2 of 2 , Jan 30, 2006
      • 0 Attachment
        Haven't heard about this in a while - did this ever get resolved for
        everyone with the latest releases?

        amla2216 wrote:
        > Hello,
        >
        > I have a problem when upgrading to Soap::Lite 0.66
        >
        > I have a simple code which worked in previous version (I replaced uri
        > by ns (using default_ns instead of ns doesn't solve the problem)).
        >
        > use SOAP::Lite + autodispatch => ns => 'FilterList', proxy =>
        > 'tcp://localhost:4444';
        > my $f = FilterList->new();
        > $f->add_new_filter('Filtre 1');
        >
        > this code now generates several warnings on both client and server
        > side "use_prefix has been deprecated. if you wish to turn off or on
        > the use of a default namespace, then please use either ns(uri) or
        > default_ns(uri) at /usr/lib/perl5/site_perl/5.8.6/SOAP/Lite.pm line 858."
        >
        > but the worse is that the second method (add_new_filter from my
        > example is never called, (it was in the previous version of SOAP::Lite)
        >
        > I'm new to SOAP::Lite and I really don't see how to make this simple
        > peace of code work in the new version.
        >
        > Any help would be gretely apprecaited.
        >
        > Michael
        >
        >
        >
        >
        > ------------------------------------------------------------------------
        > YAHOO! GROUPS LINKS
        >
        > * Visit your group "soaplite
        > <http://groups.yahoo.com/group/soaplite>" on the web.
        >
        > * To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        > <mailto:soaplite-unsubscribe@yahoogroups.com?subject=Unsubscribe>
        >
        > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service <http://docs.yahoo.com/info/terms/>.
        >
        >
        > ------------------------------------------------------------------------
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.