Loading ...
Sorry, an error occurred while loading the content.

RE: [soaplite] v0.66: use_prefix deprecated and services via WSDL

Expand Messages
  • Dan Horne
    Hi Eric Are you sure? I ve just installed the new 0.66 version SOAP::Lite on three different machines, and all exhibit the behaviour. From the uri method:
    Message 1 of 15 , Dec 30, 2005
    • 0 Attachment
      Hi Eric

      Are you sure? I've just installed the new 0.66 version SOAP::Lite on three
      different machines, and all exhibit the behaviour. From the uri method:

      $self->register_ns($self->{'_ns_uri'}) if (!$self->use_prefix);

      and use_prefix has the warning.

      Dan

      > -----Original Message-----
      > From: Eric Bridger [mailto:eric@...]
      > Sent: Saturday, 31 December 2005 7:00 a.m.
      > To: dan.horne@...
      > Cc: soaplite@yahoogroups.com
      > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via WSDL
      >
      > Hmmm. This has been an educational thread, but back to the original
      > post yesterday. The code below works as expected with no warnings about
      > use_prefix.
      >
      > On Thu, 2005-12-29 at 01:03, Dan Horne wrote:
      > > Running the standard web service example from the doco:
      > >
      > > #!/usr/local/bin/perl
      > > use SOAP::Lite;
      > > print SOAP::Lite
      > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
      > > -> getQuote('MSFT');
      > >
      > > And the warnings return:
      > >
      > > use_prefix has been deprecated. if you wish to turn off or on the use
      > of a
      > > default namespace, then please use either ns(uri) or default_ns(uri)
      > at
      > > /usr/local/lib/perl5/site_perl/5.8.7/SOAP/Lite.pm line 858.
      > >
      > > It's not clear to me how I use ns or default_ns in this instance.
      > >
      > > Regards
      > >
      > > Dan Horne
    • Eric Bridger
      Well I am still using version: .65_6 use SOAP::Lite; print SOAP::Lite - service( http://www.xmethods.net/sd/StockQuoteService.wsdl ) - getQuote( MSFT );
      Message 2 of 15 , Dec 30, 2005
      • 0 Attachment
        Well I am still using version: .65_6
        use SOAP::Lite;
        print SOAP::Lite
        -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
        -> getQuote('MSFT');
        print "\n";

        gives no warnings.

        On Fri, 2005-12-30 at 14:23, Dan Horne wrote:
        > Hi Eric
        >
        > Are you sure? I've just installed the new 0.66 version SOAP::Lite on three
        > different machines, and all exhibit the behaviour. From the uri method:
        >
        > $self->register_ns($self->{'_ns_uri'}) if (!$self->use_prefix);
        >
        > and use_prefix has the warning.
        >
        > Dan
        >
        > > -----Original Message-----
        > > From: Eric Bridger [mailto:eric@...]
        > > Sent: Saturday, 31 December 2005 7:00 a.m.
        > > To: dan.horne@...
        > > Cc: soaplite@yahoogroups.com
        > > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via WSDL
        > >
        > > Hmmm. This has been an educational thread, but back to the original
        > > post yesterday. The code below works as expected with no warnings about
        > > use_prefix.
        > >
        > > On Thu, 2005-12-29 at 01:03, Dan Horne wrote:
        > > > Running the standard web service example from the doco:
        > > >
        > > > #!/usr/local/bin/perl
        > > > use SOAP::Lite;
        > > > print SOAP::Lite
        > > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
        > > > -> getQuote('MSFT');
        > > >
        > > > And the warnings return:
        > > >
        > > > use_prefix has been deprecated. if you wish to turn off or on the use
        > > of a
        > > > default namespace, then please use either ns(uri) or default_ns(uri)
        > > at
        > > > /usr/local/lib/perl5/site_perl/5.8.7/SOAP/Lite.pm line 858.
        > > >
        > > > It's not clear to me how I use ns or default_ns in this instance.
        > > >
        > > > Regards
        > > >
        > > > Dan Horne
        >
      • Dan Horne
        .65_6 doesn t have this warning
        Message 3 of 15 , Dec 30, 2005
        • 0 Attachment
          .65_6 doesn't have this warning

          > -----Original Message-----
          > From: Eric Bridger [mailto:eric@...]
          > Sent: Saturday, 31 December 2005 8:33 a.m.
          > To: Dan Horne
          > Cc: soaplite@yahoogroups.com
          > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via WSDL
          >
          > Well I am still using version: .65_6
          > use SOAP::Lite;
          > print SOAP::Lite
          > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
          > -> getQuote('MSFT');
          > print "\n";
          >
          > gives no warnings.
          >
          > On Fri, 2005-12-30 at 14:23, Dan Horne wrote:
          > > Hi Eric
          > >
          > > Are you sure? I've just installed the new 0.66 version SOAP::Lite on
          > three
          > > different machines, and all exhibit the behaviour. From the uri method:
          > >
          > > $self->register_ns($self->{'_ns_uri'}) if (!$self->use_prefix);
          > >
          > > and use_prefix has the warning.
          > >
          > > Dan
          > >
          > > > -----Original Message-----
          > > > From: Eric Bridger [mailto:eric@...]
          > > > Sent: Saturday, 31 December 2005 7:00 a.m.
          > > > To: dan.horne@...
          > > > Cc: soaplite@yahoogroups.com
          > > > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via
          > WSDL
          > > >
          > > > Hmmm. This has been an educational thread, but back to the original
          > > > post yesterday. The code below works as expected with no warnings
          > about
          > > > use_prefix.
          > > >
          > > > On Thu, 2005-12-29 at 01:03, Dan Horne wrote:
          > > > > Running the standard web service example from the doco:
          > > > >
          > > > > #!/usr/local/bin/perl
          > > > > use SOAP::Lite;
          > > > > print SOAP::Lite
          > > > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
          > > > > -> getQuote('MSFT');
          > > > >
          > > > > And the warnings return:
          > > > >
          > > > > use_prefix has been deprecated. if you wish to turn off or on the
          > use
          > > > of a
          > > > > default namespace, then please use either ns(uri) or default_ns(uri)
          > > > at
          > > > > /usr/local/lib/perl5/site_perl/5.8.7/SOAP/Lite.pm line 858.
          > > > >
          > > > > It's not clear to me how I use ns or default_ns in this instance.
          > > > >
          > > > > Regards
          > > > >
          > > > > Dan Horne
          > >
          >
        • Dan Horne
          ... Sorry, actually that s not true, but I can t test it .65_6. Dan
          Message 4 of 15 , Dec 30, 2005
          • 0 Attachment
            > .65_6 doesn't have this warning

            Sorry, actually that's not true, but I can't test it .65_6.

            Dan

            > -----Original Message-----
            > From: soaplite@yahoogroups.com [mailto:soaplite@yahoogroups.com] On Behalf
            > Of Dan Horne
            > Sent: Saturday, 31 December 2005 8:45 a.m.
            > To: 'Eric Bridger'
            > Cc: soaplite@yahoogroups.com
            > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via WSDL
            >
            > .65_6 doesn't have this warning
            >
            > > -----Original Message-----
            > > From: Eric Bridger [mailto:eric@...]
            > > Sent: Saturday, 31 December 2005 8:33 a.m.
            > > To: Dan Horne
            > > Cc: soaplite@yahoogroups.com
            > > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services via
            > WSDL
            > >
            > > Well I am still using version: .65_6
            > > use SOAP::Lite;
            > > print SOAP::Lite
            > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
            > > -> getQuote('MSFT');
            > > print "\n";
            > >
            > > gives no warnings.
            > >
            > > On Fri, 2005-12-30 at 14:23, Dan Horne wrote:
            > > > Hi Eric
            > > >
            > > > Are you sure? I've just installed the new 0.66 version SOAP::Lite on
            > > three
            > > > different machines, and all exhibit the behaviour. From the uri
            > method:
            > > >
            > > > $self->register_ns($self->{'_ns_uri'}) if (!$self->use_prefix);
            > > >
            > > > and use_prefix has the warning.
            > > >
            > > > Dan
            > > >
            > > > > -----Original Message-----
            > > > > From: Eric Bridger [mailto:eric@...]
            > > > > Sent: Saturday, 31 December 2005 7:00 a.m.
            > > > > To: dan.horne@...
            > > > > Cc: soaplite@yahoogroups.com
            > > > > Subject: RE: [soaplite] v0.66: use_prefix deprecated and services
            > via
            > > WSDL
            > > > >
            > > > > Hmmm. This has been an educational thread, but back to the
            > original
            > > > > post yesterday. The code below works as expected with no warnings
            > > about
            > > > > use_prefix.
            > > > >
            > > > > On Thu, 2005-12-29 at 01:03, Dan Horne wrote:
            > > > > > Running the standard web service example from the doco:
            > > > > >
            > > > > > #!/usr/local/bin/perl
            > > > > > use SOAP::Lite;
            > > > > > print SOAP::Lite
            > > > > > -> service('http://www.xmethods.net/sd/StockQuoteService.wsdl')
            > > > > > -> getQuote('MSFT');
            > > > > >
            > > > > > And the warnings return:
            > > > > >
            > > > > > use_prefix has been deprecated. if you wish to turn off or on the
            > > use
            > > > > of a
            > > > > > default namespace, then please use either ns(uri) or
            > default_ns(uri)
            > > > > at
            > > > > > /usr/local/lib/perl5/site_perl/5.8.7/SOAP/Lite.pm line 858.
            > > > > >
            > > > > > It's not clear to me how I use ns or default_ns in this instance.
            > > > > >
            > > > > > Regards
            > > > > >
            > > > > > Dan Horne
            > > >
            > >
            >
            >
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.