Loading ...
Sorry, an error occurred while loading the content.

array element type mismatch

Expand Messages
  • activlinks
    hi, i having a problem working with Array element, please help! ...
    Message 1 of 1 , Nov 1, 2005
    • 0 Attachment
      hi,

      i having a problem working with Array element, please help!
      here is partial of the schema:


      --------------------------------------------------------
      <complexType name="createCustomer">
      <sequence>
      <element name="Customer_1" nillable="true"
      type="tns:Customer"/></sequence></complexType>

      <complexType name="Customer">
      <sequence>
      <element maxOccurs="unbounded" minOccurs="0"
      name="addresses" nillable="true" type="tns:Address"/>
      ...</sequence></complexType>

      <complexType name="Address">
      <sequence>
      ...</sequence></complexType>
      ------------------------------------------------


      i manage to the serialize the soap message as follow:


      --------------------------------------------------------
      <createCustomer xmlns="urn:CustomerService">

      <Customer_1>
      ...
      <addresses xsi:type="SOAP-ENC:Array"
      SOAP-ENC:arrayType="Address[2]">
      <Address xsi:type="Address">
      ...
      </Address>
      <Address xsi:type="Address">
      ...
      </Address>

      </addresses>
      </Customer_1>

      </createCustomer>
      --------------------------------------------------------

      but the service on the server doesn't like that and response with
      array element type mismatch. please let me know what is the problem.
      thanks!
    Your message has been successfully submitted and would be delivered to recipients shortly.