Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] SOAP::Lite Install with mod_perl on RH3 Enterprise?

Expand Messages
  • Aaron Trevena
    ... Looks like you have neither Modperl 1 or 2 installed - there were some API changes between 1.99 and 2.x. My suggestion is to either build your own
    Message 1 of 2 , Sep 23, 2005
    View Source
    • 0 Attachment
      On 9/15/05, w1ntermute03 <ergeorge@...> wrote:
      > Hi,
      > Trying to do this on a RedHat 3 Enterprise box - I want to run it with
      > Apache/mod_perl, but when I specify that in the makefile process I get:
      >
      > Warning: prerequisite Apache 0 not found.
      >
      > I know mod_perl is installed, via rpm in this case
      > (mod_perl-1.99_09-10.ent) When I list the RPM contents don't find an
      > Apache.pm, but rather an Apache2.pm (I am using Apache 2.0.46) I try
      > including it anyway:
      >
      > perl -I
      > /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Apache2.pm
      > Makefile.PL
      >
      > But still the same error?!
      >
      > There is also an /usr/lib/perl5/5.8.0/CGI/Apache.pm on the system, but
      > including that doesn't help either. Any other ideas?

      Looks like you have neither Modperl 1 or 2 installed - there were some
      API changes between 1.99 and 2.x.

      My suggestion is to either build your own apache/mod_perl from scratch
      or maybe upgrade.

      If you don't want to change your current setup, I think RHEL3 will
      have mod_proxy installed so you could proxy an apache1.3 with matching
      mod_perl behind for your soap stuff, failing that you could hack
      SOAP::Lite to use Apache2.

      Cheers,

      A.
    Your message has been successfully submitted and would be delivered to recipients shortly.