Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] mod_perl, apache-2 and soap::lite?

Expand Messages
  • Andre Merzky
    Hi Brad, thanks for the piece, I will try that as well, and will let you know if I get any other hints... Cheers, Andre. ... --
    Message 1 of 3 , Jun 10, 2005
    • 0 Attachment
      Hi Brad,

      thanks for the piece, I will try that as well, and will let
      you know if I get any other hints...

      Cheers, Andre.


      Quoting [Brad Miele] (Jun 10 2005):
      > Date: Fri, 10 Jun 2005 15:06:53 -0400
      > From: Brad Miele <brad.miele@...>
      > To: Andre Merzky <andre@...>
      > Subject: Re: [soaplite] mod_perl, apache-2 and soap::lite?
      > Cc: "SOAP::Lite Mailing List" <soaplite@yahoogroups.com>
      >
      >
      > I would be interested in seeing any responses that you get on this. I had a
      > heck of a time getting a SOAP::Lite service running smoothly under
      > apache2/mp. Here is what i have now, don't know how correct it is:
      > in httpd.conf :
      > <FilesMatch "\.asmx$"> <--- couldn't resist
      > SetHandler perl-script
      > PerlHandler Apache::SOAP
      > PerlSetVar dispatch_to "/usr/local/apache/modules,
      > NotRealWebServiceName::Search, NotRealWebServiceName::Login"
      > </FilesMatch>
      > i haven't had any header issues,
      > the last thing that i do to the xml before i send it out is:
      > return $soapitup($xml);
      > sub soapitup {
      > my ($self,$body) = @_;
      > my $elem = SOAP::Data
      > ->type('xml' => $body);
      > return $elem;
      > }
      >
      > On 6/10/05, Andre Merzky <[1]andre@...> wrote:
      >
      > I might be missing the obvious, but I don't seem to be able
      > to get SOAP::Lite working on apache2/perl_mod without stupid
      > hacks. In particular, apache2/modperl seems to send the
      > header stuff (Content-type: text/xml; charset=utf-8\n\n
      > etc), and SOAP::Lite seems to send it again. If I filter
      > that out in XML/Parser.pm (Ugh!) evrython works fine.
      > Now, I goggled and searched archive, and the way seems to
      > use different soap transport, so instead of
      > SOAP::Transport::HTTP::CGI
      > as proposed by SOAP::Lite docu, use
      > SOAP::Transport::HTTP::Apache
      > SOAP::HTTP2
      > or something. Well, that is the question really: I did not
      > get any of the suggestions running successfully: either did
      > not fix the problem, or did not work with Apache2 and
      > mod_perl.
      > Anybody having that running cleanly?
      > Or anybody knows how I can tell SOAP::Lite to shut up and
      > just send the XML, nothing before?
      > Many thanks, Andre.
      --
      +-----------------------------------------------------------------+
      | Andre Merzky | phon: +31 - 20 - 598 - 7759 |
      | Vrije Universiteit Amsterdam (VU) | fax : +31 - 20 - 598 - 7653 |
      | Dept. of Computer Science | mail: merzky@... |
      | De Boelelaan 1083a | www: http://www.merzky.net |
      | 1081 HV Amsterdam, Netherlands | |
      +-----------------------------------------------------------------+
    Your message has been successfully submitted and would be delivered to recipients shortly.