Loading ...
Sorry, an error occurred while loading the content.

Can't locate object method "blocking"

Expand Messages
  • ampergo
    I basically did as the example said: my $key= KEYGOESHERE ; #my $query= foo ; my $googleSearch = SOAP::Lite - service( file:GoogleSearch.wsdl ); my $result =
    Message 1 of 1 , Mar 22, 2005
      I basically did as the example said:

      my $key='KEYGOESHERE';
      #my $query="foo";
      my $googleSearch = SOAP::Lite -> service("file:GoogleSearch.wsdl");
      my $result = $googleSearch -> doGoogleSearch($key, $q, 0, 10,
      "false", "", "false", "", "latin1", "latin1");
      print "About $result->{'estimatedTotalResultsCount'} results.\n";

      and on the $resukt line I get the following error:

      500 Can't locate object method "blocking" via package
      "LWP::Protocol::http::Socket" at hax.cgi line 77

      $q is just a string that I get from a text edit in a form.

      These are the versions of various modules:

      HTML Parser 3.45
      libwww-perl 5.803
      URI 1.35
      SOAP Lite 0.6

      I have also tried SOAP Lite 0.55 (the oldest one available on CPAN)
      but that didn't work either. I have tried an older libwww-perl as
      well, but that didn't happen. I did this thinking this "blocking"
      method was removed at some point.

      I then proceeded to try Net::Google, like this (exactly like the
      example shows):

      use constant LOCAL_GOOGLE_KEY => "KEYGOESHERE";

      my $google = Net::Google->new(key=>LOCAL_GOOGLE_KEY);
      my $search = $google->search();

      # Search interface
      $search->query(qw(aaron straup cope));
      $search->lr(qw(en fr));

      map { print $_->title()."\n"; } @{$search->results()};

      It gave this error:

      Can't locate object method "blocking" via package
      "LWP::Protocol::http::Socket" at
      /home/notry/public_html/perl/SOAP-Lite-0.60/lib/SOAP/Lite.pm line 3006

      I do not have LWP or SOAP::Lite actaully installed on the machine.
      they are just in my webspace, and I use use lib "..." pragmas.

      I am not sure what the problem could be. Any suggestions regarding
      this are very appreciated.

    Your message has been successfully submitted and would be delivered to recipients shortly.