Loading ...
Sorry, an error occurred while loading the content.

Re: Windows release for 0.65-beta2...?

Expand Messages
  • h2ofaull
    Sorry for the wrong wording - it was late. :) I surely didn t mean compile , rather install . Thank you again for the help! I still don t understand why
    Message 1 of 3 , Feb 9, 2005
      Sorry for the wrong wording - it was late. :) I surely didn't mean
      "compile", rather "install".

      Thank you again for the help! I still don't understand why some of
      the tarballs are labeled "Windows" and some "UNIX/Linux" if they're
      the same... but everything installed and works the same as in Linux -
      all I needed to do was use "nmake" instead of make. Details of why I
      made this mistake are below.

      If all of the S::L bundles are the same (except version), why are some
      labeled Windows vice UNIX distribution? The latest distribution
      (0.65-beta2 is labeled "UNIX/Linux" and the most recent one labeled
      Windows is version 0.55 - I should have checked further, but I
      believed that they were different. I've run into a lot of little
      things that are different with Perl in Windows vice UNIX, so being
      different was not surprising to me.

      My problem was that I used the Cygwin make rather than nmake. I found
      this site

      which reduced my inhibitions about using nmake. Downloaded and
      installed nmake, then unpacked and installed the "UNIX/Linux"
      0.65-beta2 S::L and everything worked fine. Sorry for the spam, I
      should have tried a little bit harder.

      The rest of this note is info for newbies (like me) that may be
      searching for error messages and stuff (like me. :)

      When I used make, which I assumed would work, I got the following errors:

      when doing `perl Makefile.PL`,
      Warning: Use of "require" without parentheses is ambiguous at (eval
      35) line 1.
      Warning: Use of "require" without parentheses is ambiguous at (eval
      36) line 1.

      Not fatal, looked fine. Ignored it.

      when doing `make`, I got the following:
      Makefile:425: *** multiple target patterns. Stop.

      Anyway, looked at it, got confused, gave up.

      I saw the docs that said "use nmake" but I already had make, so I
      assumed it should have worked - it didn't. For any of you struggling
      with this - struggle no longer. Go to the URL above, follow links to
      download nmake from Microsoft... then follow the instructions like I
      should have. :)

      Thanks again,


      --- In soaplite@yahoogroups.com, Duncan Cameron
      <duncan_cameron2002@y...> wrote:
      > --- h2ofaull <h2ofaull@y...> wrote:
      > >
      > >
      > > Greetings!
      > >
      > > I have need for some of the new features / fixes that have been
      > > released in SOAP::Lite 0.65-beta2 - but I have need for this in
      > > Windows (unfortunately...)
      > >
      > > Is an updated Windows release in progress? Planned? Needed? I
      > > don't
      > > see any mention of this on soaplite.com.
      > SOAP::Lite is Perl only, so it is not dependent on any OS. The install
      > works quite happily on Windows.
      > >
      > > I don't know anything about what is required to port S::L to Windows,
      > > aside from the fact that with a small amount of effort I was not able
      > > to get the UNIX dist to compile under Windows or Cygwin.
      > You don't *compile* anything, just install.
      > What problems were you getting? Note that some of the tests may fail
      > depending on which components you select.
      > Duncan
      > ___________________________________________________________
      > ALL-NEW Yahoo! Messenger - all new features - even more fun!
    Your message has been successfully submitted and would be delivered to recipients shortly.