Loading ...
Sorry, an error occurred while loading the content.

problems after upgrading from 0.55

Expand Messages
  • dchallender
    Active State Perl 5.8 Win 2K Script was running OK with Soap lite 0.55 Added soap lite 0.65 beta 2.1 (as I wanted to see if better support for WSDL schemas
    Message 1 of 1 , Jan 12, 2005
    • 0 Attachment
      Active State Perl 5.8
      Win 2K

      Script was running OK with Soap lite 0.55

      Added soap lite 0.65 beta 2.1 (as I wanted to see if better support
      for WSDL schemas than 0.55)
      Just did:
      perl Makefile.PL
      nmake
      nmake test
      nmake install

      (using MS nmake)

      (interestingly ppm still shows 0.55 as the soap lite version)

      Script that used to run OK, now gives errors.

      Run, get multiple output (29 lines) of:
      document/literal support is EXPERIMENTAL in SOAP::Lite at
      C:/Perl/site/lib/SOAP/Lite.pm line 2730.

      Followed by, final message of:
      Can't call method "name" without a package or object reference at
      C:/Perl/site/l
      ib/SOAP/Lite.pm line 2856.


      Contents of script, pruned to remove extraneous details, but even at
      "minimum" level below gives error:
      experimentalsoap.pl

      #!perl -w

      use SOAP::Lite;

      my $trial =

      SOAP::Lite->service("http://wx24dev/webservices/DataServices.asmx?WSDL");


      print $trial->LoginUser();


      (local network based development machine hosting the web services, not
      publically accessible).

      In case anyone asks, there is a LoginUser web serviceĀ…

      I am guessing something went wring with the upgrade of soap lite to
      the beta (or problem with the beta)?



      (Apols if any etiquette of the group breached, did variety of web
      searches for possible solution with no success, and so joined this
      group and posted in hope of an answer)

      Regards

      Dave
    Your message has been successfully submitted and would be delivered to recipients shortly.