Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Content in Prolog?

Expand Messages
  • Holger Dürer
    Sorry cannot help as I am still trying to understand the problem (but maybe others have the same difficulty seeing what it is, so clarifying it may help them
    Message 1 of 2 , Dec 16, 2004
    • 0 Attachment
      Sorry cannot help as I am still trying to understand the problem (but
      maybe others have the same difficulty seeing what it is, so clarifying
      it may help them help you :-) )


      On Wed, 2004-12-15 at 17:24, chuckcott wrote:
      [...]
      > And here is what it looks like on the server:
      > ------------------------------------------------------------------
      > accept: text/xml
      > Method: POST
      > charset: utf-8
      > content-length: 651
      > user-agent: SOAP::Lite/Perl/0.60
      > Protocol: HTTP/1.0
      > URI: /webservices/xocomm/cdbtest
      > content-type: text/xml; charset=utf-8
      > host: plagtrtst01:8000
      > soapaction:
      > "http://plagtrtst01:8000/webservices/xocomm/cdbtest#ADD_SOAP_ENVELOPING"
      >
      > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      > xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      > SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Bod\
      > y><namesp1:ADD_SOAP_ENVELOPING
      > xmlns:namesp1="http://plagtrtst01:8000/webservices/xocomm/cdbtest"><c-gensym3
      > xsi:type="xsd:string">webservices/xocomm/cdbtest</c-gensym3><c-gensym5
      > xsi:type="xsd:string">This is more
      > text</c-gensym5></namesp1:ADD_SOAP_ENVELOPING></SOAP-ENV:Body></SOAP-ENV:Envelop\
      > e>
      >
      > ------------------------------------------------------------------
      >
      > I guess my question is: How can I get rid of the data before the
      > xml tag?
      >
      What data before the xml tag? Or rather what xml tag?

      >From a casual glance it all seems fine -- the HTTP headers followed by
      the (unreadably formatted) SOAP request.
      Pretty printing the requests gives:
      ,----
      | <?xml version='1.0' encoding='UTF-8'?>
      | <SOAP-ENV:Envelope
      | xmlns:SOAP-ENV='http://schemas.xmlsoap.org/soap/envelope/'
      | xmlns:xsi='http://www.w3.org/1999/XMLSchema-instance'
      | xmlns:SOAP-ENC='http://schemas.xmlsoap.org/soap/encoding/'
      | xmlns:xsd='http://www.w3.org/1999/XMLSchema'
      |
      SOAP-ENV:encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'>
      | <SOAP-ENV:Body>
      | <namesp1:ADD_SOAP_ENVELOPING
      xmlns:namesp1='http://plagtrtst01:8000/webservices/xocomm/cdbtest'>
      | <c-gensym3
      xsi:type='xsd:string'>webservices/xocomm/cdbtest</c-gensym3>
      | <c-gensym5 xsi:type='xsd:string'>This is more text</c-gensym5>
      | </namesp1:ADD_SOAP_ENVELOPING>
      | </SOAP-ENV:Body>
      | </SOAP-ENV:Envelope>
      `----
      And that seems not too bad...

      So what am I missing or misunderstanding?

      [...]
    Your message has been successfully submitted and would be delivered to recipients shortly.