Loading ...
Sorry, an error occurred while loading the content.

content type UTF and iso

Expand Messages
  • grp_member
    Hi, I am getting the following error at my client when I try to use Apache::Registry mod_perl in my service: Unexpected Content-Type text/plain;
    Message 1 of 1 , Dec 7, 2004
    • 0 Attachment
      Hi,

      I am getting the following error at my client when I try to use
      Apache::Registry mod_perl in my service:
      Unexpected Content-Type 'text/plain; charset=iso-8859-1' returned

      The response message (with tracing on) appears to be correct. I do
      not set charset to utf or iso on the server side so this is default.
      When I run a CGI based server the return type is utf.

      CGI Service Response:
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
      Connection: close
      Date: Wed, 08 Dec 2004 03:42:51 GMT
      Content-Type: text/xml; charset=utf-8 <------------------
      Client-Date: Wed, 08 Dec 2004 03:38:08 GMT
      Client-Response-Num: 1

      Apache::Registry (mod_perl) service response:
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
      Connection: close
      Date: Wed, 08 Dec 2004 03:42:51 GMT
      Content-Type: text/plain; charset=iso-8859-1 <-----------
      Client-Date: Wed, 08 Dec 2004 03:38:41 GMT
      Client-Response-Num: 1

      How do I change my service to return UTF for mod perl service? I saw
      the example on the website on how to send strings encoded from the
      client but I need to know the reverse. Any help would be appreciated.

      Regards
      grp_member
    Your message has been successfully submitted and would be delivered to recipients shortly.