Loading ...
Sorry, an error occurred while loading the content.

SOAP::Lit 0.65 Beta 2 Available

Expand Messages
  • Byrne Reese
    Wow, SOAP::Lite went from not having a release in one year, to having 2 in 2 weeks. This is a dangerous precedent to set, let me tell ya. But without further
    Message 1 of 5 , Oct 26, 2004
    • 0 Attachment

      Wow, SOAP::Lite went from not having a release in one year, to having 2 in 2 weeks. This is a dangerous precedent to set, let me tell ya. But without further ado, let me announce the release of SOAP::Lite version 0.65 Beta 2. This release contains almost as many changes as the first, including some of the following:

      • Developers can now specify their own User Agent class for their SOAP clients.
      • DIME hooks have been added, assuring DIME support for this release - however, DIME is still not functional until needed patches are made to DIME::Tools.
      • Developers now have access to stub code generated from WSDLs. This code can be output to a file to help in debugging, and service generation.
      • One is now able to construct envelopes with null SOAP Bodies.
      • One now has direct access to the LWP::UserAgent class used by SOAP::Schema to fetch WSDLs. This is helpful if your WSDL requires authentication.
      • Documentation refinements including refactored README, ReleaseNotes.txt, and more.

      View a complete change log of the release.

      SOAP::Lite is growing and changing substantiall. We need your help in testing this very critical release, So please, download, install, and test out SOAP::Lite now.

      Byrne


    • Bernd Prager
      With the new release I m currently getting: /literal is not supported in this version of SOAP::Lite at /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
      Message 2 of 5 , Oct 26, 2004
      • 0 Attachment
        With the new release I'm currently getting:

        /literal is not supported in this version of SOAP::Lite at
        /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.

        -- Bernd
      • Bernd Prager
        changing encoding to encoded breaks as well: Use of uninitialized value in string eq at /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2727. Use of
        Message 3 of 5 , Oct 26, 2004
        • 0 Attachment
          changing encoding to "encoded" breaks as well:

          Use of uninitialized value in string eq at
          /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2727.
          Use of uninitialized value in string eq at
          /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2727.
          Use of uninitialized value in concatenation (.) or string at
          /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
          /encoded is not supported in this version of SOAP::Lite at
          /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.


          --- In soaplite@yahoogroups.com, "Bernd Prager" <bernd@p...> wrote:
          >
          > With the new release I'm currently getting:
          >
          > /literal is not supported in this version of SOAP::Lite at
          > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
          >
          > -- Bernd
        • Byrne Reese
          I am looking into this post-haste, and will issue a patch ASAP. Byrne
          Message 4 of 5 , Oct 26, 2004
          • 0 Attachment
            I am looking into this post-haste, and will issue a patch ASAP.

            Byrne

            Bernd Prager wrote:

            >
            > changing encoding to "encoded" breaks as well:
            >
            > Use of uninitialized value in string eq at
            > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2727.
            > Use of uninitialized value in string eq at
            > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2727.
            > Use of uninitialized value in concatenation (.) or string at
            > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
            > /encoded is not supported in this version of SOAP::Lite at
            > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
            >
            >
            > --- In soaplite@yahoogroups.com, "Bernd Prager" <bernd@p...> wrote:
            > >
            > > With the new release I'm currently getting:
            > >
            > > /literal is not supported in this version of SOAP::Lite at
            > > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
            > >
            > > -- Bernd
          • Byrne Reese
            This die will be turned off in the next release.
            Message 5 of 5 , Oct 27, 2004
            • 0 Attachment
              This "die" will be turned off in the next release.

              Bernd Prager wrote:

              >
              > With the new release I'm currently getting:
              >
              > /literal is not supported in this version of SOAP::Lite at
              > /usr/lib/perl5/site_perl/5.8.2/SOAP/Lite.pm line 2739.
              >
              > -- Bernd
            Your message has been successfully submitted and would be delivered to recipients shortly.