Loading ...
Sorry, an error occurred while loading the content.

Re: Biztalk server with soaplite client?

Expand Messages
  • Issac Goldstand
    See, the problem with doing something new is that you become the resident expert , which I really shouldn t be as I didn t succeed from deep understanding of
    Message 1 of 1 , Sep 19, 2004
    • 0 Attachment
      See, the problem with doing something new is that you become the "resident
      expert", which I really shouldn't be as I didn't succeed from deep
      understanding of either soaplit or .Net, but rather reading as much as I
      could and throwing requests and responses and different WSDL across until
      something worked. What I would suggest is getting the MS .NET generic SOAP
      client, which I'm sure I've posted a link to (if you can't find it, email me
      offlist and I'll send you a .zip - actually, if enough people ask, I can see
      about posting the tools and toolkits online). Anyway, get the toolkit, and
      look at exactly what you're getting sent to your BizTalk server. Then,
      start playing with the soapsh.pl script that comes with soaplite (put all
      debug messages on by entering "on_debug(sub{print@_})" in the soapsh.pl
      shell) and keep playing with the serializers and with the WSDL (although I'd
      favor the former since soaplite is known to not have strong WSDL support)
      until the XML matches what .Net did. That's basically how I did it.

      Issac

      ----- Original Message -----
      From: "aviannachao" <aviannachao@...>
      To: <margol@...>
      Sent: Wednesday, September 15, 2004 10:36 PM
      Subject: Biztalk server with soaplite client?


      > Hi Issac,
      >
      > I read your post
      > (http://groups.yahoo.com/group/soaplite/message/3770), but I am
      > currently having problems going the other way, I have a soaplite
      > client trying to connect to a Biztalk web service (my full question at
      > http://groups.yahoo.com/group/soaplite/message/3927).
      >
      > The short of it is Biztalk receives my request, but thinks my request
      > is blank.
      >
      > I did see the MS article
      > http://support.microsoft.com/default.aspx?scid=kb;en-us;308438, and
      > tried doing what they suggested (renaming s and to xsd, and so on),
      > but it still does not work, actually the XML it generates is exactly
      > the same as if I didn't do the renaming. The article also says "4.
      > Remove all elements that involve the HTTP GET and HTTP POST messages,
      > portTypes, bindings, and service ports." Do you have any idea what
      > this means? If I remove all the portTypes, bindings and service
      > ports, then the WSDL page won't be complete anymore, and my soaplite
      > client can't find the method/service.
      >
      > Thanks in advance,
      > Avianna
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.