Loading ...
Sorry, an error occurred while loading the content.

problem connecting to Apache soap web service

Expand Messages
  • nonsolosoft
    Hi, it s since last week that I m trying to connect to a simple soap web service but without success. Here there are some output and data: bash-2.05$
    Message 1 of 1 , Jul 18, 2004
    • 0 Attachment
      Hi,

      it's since last week that I'm trying to connect to a simple soap web
      service but without success.

      Here there are some output and data:

      bash-2.05$ stubmaker.pl http://incipit.unito.it/ocap/sm.wsdl
      Accessing...
      Unresolved (wrong?) href (http://incipit.unito.it/ocap/sm.xsd) in
      element '{http://www.w3.org/2001/XInclude}include'

      http://incipit.unito.it/ocap/sm.wsdl
      http://incipit.unito.it/ocap/sm.xsd

      I've checked the sm.wsdl file on xmethods.com and it seems good
      enoght for them.

      Here there are envelopes of input and output:

      SOAP::Transport::HTTP::Client::send_receive: POST
      http://fake:fakepass@.../indice/servlet/soapserver HTTP/1.1
      Accept: text/xml
      Accept: multipart/*
      Content-Length: 1061
      Content-Type: text/xml; charset=utf-8
      SOAPAction: "urn:remotehost.it/SbnmarcService#Esegui"

      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-E\
      NV="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1\
      :Esegui xmlns:namesp1="urn:remotehost.it/SbnmarcService"><SBNMarc
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      schemaVersion="1.06" xsi:noNamespaceSchemaLocation="SBNMarc\
      v106.xsd"><SbnUser><Biblioteca
      xsi:type="xsd:string">fakebibid</Biblioteca><UserId
      xsi:type="xsd:int">fakeuser</UserId></SbnUser>
      <SbnMessage><SbnRequest><Cerca tipoOrd="1" tipoOutput="000\
      " maxRighe="15"
      numPrimo="1"><CercaElementoAut><CercaDatiAut><tipoAuthority
      xsi:type="xsd:string">AU</tipoAuthority><canaliCercaDatiAut><T001
      xsi:type="xsd:string">CFIV006324</T001><\
      /canaliCercaDatiAut></CercaDatiAut></CercaElementoAut></Cerca></SbnRequest></SbnMessage></SBNMarc></namesp1:Esegui></SOAP-ENV:Body></SOAP-ENV:Envelope>
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
      Connection: close
      Date: Mon, 19 Jul 2004 01:14:44 GMT
      Server: Jetty/4.1.3 (Windows 2000 5.0 x86)
      Content-Length: 657
      Content-Type: text/xml; charset="utf-8"
      Client-Date: Mon, 19 Jul 2004 01:16:24 GMT
      Client-Peer: 193.109.105.8:80
      Client-Response-Num: 1
      Servlet-Engine: Jetty/4.1.3 (Servlet 2.3; JSP 1.2; java 1.3.1)
      SOAPAction: ""

      <SOAP-ENV:Envelope
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Header><hs:schema_version
      xmlns:hs="http://remotehost.it/indice/header">1.06</hs:schema_ver\
      sion><hs:schema_url
      xmlns:hs="http://remotehost.it/indice/header">http://remotehost.it/indice/SBNMarcv106.xsd</hs:schema_url></SOAP-ENV:Header><SOAP-ENV:Body><SBNMarc
      schemaVer\
      sion="1.06"><SbnUser><Biblioteca> </Biblioteca><UserId>
      </UserId></SbnUser><SbnMessage><SbnResponse><SbnResult><esito>5600</esito><testoEsito>Errore
      interno all'applicazion\
      e</testoEsito></SbnResult><SbnOutput/></SbnResponse></SbnMessage>
      </SBNMarc></SOAP-ENV:Body></SOAP-ENV:Envelope>

      Only remotehost and fakeuser and password have been changed above.

      Can you suggest me something usefull to use SOAP::Lite with success
      with this web service?


      Thank you in advance, \fer
    Your message has been successfully submitted and would be delivered to recipients shortly.