Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] client-junk in SOAP server response ? soap client unable to decode..Help Needed

Expand Messages
  • subrata kolay
    Dear Dancan, yes..you are right..below i have given that portion. Client-Junk:
    Message 1 of 5 , May 12, 2004
    • 0 Attachment
      Dear Dancan,

      yes..you are right..below i have given that portion.

      Client-Junk: <?xml version="1.0"
      >encoding="UTF-8"?><SOAP-ENV:Envelope
      >xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"

      How it comes ? and how to rectify it? why my client
      unable to decode ? is it due to client-junk header?

      please help me ...i am stuck here..

      Thanks & Regards
      subrata kolay

      --- "duncan_cameron2002@..."
      <duncan_cameron2002@...> wrote:
      ---------------------------------
      On 12-05-2004 at 04:23:13 subrata kolay
      <subrata_79in@...> wrote:

      >Dear All,
      >
      >I am stuck here..please reply...
      >
      >At the time of testing a simple soap message in my
      >test kit(I830M4 chipset intel motherboard having x86
      >processor), response coming from server is not
      decoded
      >at client !!
      >i am giving soap trace response as well as my simple
      >script. why "client-junk" is coming at SOAP response
      >?...
      >1> my soap server is http daemon (mini_agent.pl) on
      >wince 4.2
      >2> soap client is (soap:lite) perl
      >(run_tests_remotely.pl) on winxp
      >3> my called perl module is (test_suite.pm) on
      >wince 4.2
      >
      >Can anyone help me to find out the solution?
      >Thanks in advance
      >
      >Thanks & Regards
      >Subrata kolay
      >
      ># soap trace result
      >SOAP::Transport::HTTP::Client::send_receive: POST
      >http://172.18.23.245:2020/
      >Accept: text/xml
      >Accept: multipart/*
      >Content-Length: 443
      >Content-Type: text/xml; charset=utf-8
      >SOAPAction: "/test_suite1#getPropList"
      >
      ><?xml version="1.0"
      >encoding="UTF-8"?><SOAP-ENV:Envelope
      >xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      >xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      >xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      >xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      >SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:getPropList
      >xmlns:namesp1="/test_suite1"/></SOAP-ENV:Body></SOAP-ENV:Envelope>
      >SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1
      >200 (OK) OK
      >
      >Date: Fri, 07 May 2004 16:32:23 GMT
      >
      >Server: libwww-perl-daemon/1.33
      >
      >Content-Length: 535
      >
      >Content-Type: text/xml; charset=utf-8
      >
      >Client-Date: Fri, 07 May 2004 14:56:52 GMT
      >Client-Junk: <?xml version="1.0"
      >encoding="UTF-8"?><SOAP-ENV:Envelope
      >xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      >xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      >xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      >xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      >SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp10:getPropListResponse
      >xmlns:namesp10="/test_suite1"><s-gensym30
      >xsi:type="xsd:string">hello</s-gensym30></namesp10:getPropListResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>
      >Client-Peer: 172.18.23.245:2020
      >Client-Response-Num: 1
      >SOAPServer: SOAP::Lite/Perl/0.55

      I don't understand. Are you saying that your server is
      sending an HTTP header called 'Client-Junk', that
      contains the SOAP response?

      Regards
      Duncan



      Yahoo! Groups Sponsor ADVERTISEMENT


      ---------------------------------
      Yahoo! Groups Links

      To visit your group on the web, go to:
      http://groups.yahoo.com/group/soaplite/

      To unsubscribe from this group, send an email to:
      soaplite-unsubscribe@yahoogroups.com

      Your use of Yahoo! Groups is subject to the Yahoo!
      Terms of Service.


      ________________________________________________________________________
      Yahoo! India Matrimony: Find your partner online. http://yahoo.shaadi.com/india-matrimony/
    • Duncan Cameron
      ... I have no knowledge of WinCE but from a brief look it appears that perl for WinCE does not include HTTP support. How have you provided that? Regards Duncan
      Message 2 of 5 , May 13, 2004
      • 0 Attachment
        >Dear Dancan,
        >
        >yes..you are right..below i have given that portion.
        >
        >Client-Junk: <?xml version="1.0"
        >>encoding="UTF-8"?><SOAP-ENV:Envelope
        >>xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
        >
        >How it comes ? and how to rectify it? why my client
        >unable to decode ? is it due to client-junk header?
        >
        >please help me ...i am stuck here..

        I have no knowledge of WinCE but from a brief look it appears that perl for WinCE does not include HTTP support. How have you provided that?

        Regards
        Duncan
      • subrata kolay
        Dear All, Please see the Dancan reply ..Can anybody tell me why it is happen so....How to solve it..? please help me... Thanks & Regards Subrata kolay ...
        Message 3 of 5 , May 13, 2004
        • 0 Attachment
          Dear All,

          Please see the Dancan reply ..Can anybody tell me why
          it is happen so....How to solve it..?

          please help me...

          Thanks & Regards
          Subrata kolay

          --- Duncan Cameron <duncan_cameron2002@...>
          wrote: > >Dear Dancan,
          > >
          > >i downloded perl 8.5.2 source and then cross
          > compiled
          > >for wince 4.2 (target) according to
          > >http://www.sourceforge.net and downloaded that
          > perl
          > >binary distribution on wince 4.2. at the same time
          > i
          > >downloded the SOAP::Lite (ver 0.55) from
          > soaplite.com
          > >and copied to wince 4.2(target)
          > >
          > >I have tested that from client soap(running on
          > winxp)
          > >,i can run exe on wince target, soap response
          > message
          > >is also coming back to client (seen from trace
          > result)
          > >but that result contain client-junk .
          > >
          > >Thanks & Regards
          > >Subrata kolay
          >
          > The Client-Junk header is created by
          > LWP::Protocol::http on the _client_ if it gets
          > headers that it does not recognise. In your case it
          > is treating the data content as a header which may
          > mean that the WinCE server is mixing headers and
          > data. Not sure why that should happen though.
          >
          > Regards
          > Duncan
          >
          >

          ________________________________________________________________________
          Yahoo! India Matrimony: Find your partner online. http://yahoo.shaadi.com/india-matrimony/
        Your message has been successfully submitted and would be delivered to recipients shortly.