Loading ...
Sorry, an error occurred while loading the content.

Re: Oh the irony - I need help...

Expand Messages
  • Byrne Reese
    Stephane, You saved me. The strace did the trick - I should ve known that trick. ... Anyway - strace told me exactly where the permission problem was - there
    Message 1 of 4 , Apr 6 7:37 AM
    • 0 Attachment
      Stephane,

      You saved me. The strace did the trick - I should've known that trick.
      :) But I didn't. :/

      Anyway - strace told me exactly where the permission problem was - there
      were quite a few actually - and presto everything started working again.

      Thanks again!
      Byrne

      Stephane Bortzmeyer wrote:

      > On Tue, Apr 06, 2004 at 10:19:38PM -0000,
      > Byrne Reese <byrne@...> wrote
      > a message of 53 lines which said:
      >
      >
      >>So the state of my system, which was once Redhat 7.3 running perl
      >>5.6.1, is now running Redhat 9 (in theory), and perl 5.8.3
      >
      >
      > RedHat, like FreeBSD, does not really support upgrades. It is probably
      > better to reinstall.
      >
      >
      >>When I run the script from the command line as ROOT it works. Ok, so
      >>this naturally leads me to believe that I have a permissions
      >>problem. But where!?
      >
      >
      > As non-root:
      >
      > % strace perl YOUR-SCRIPT.pl |& grep -i permission
      >
      > Should give you something like:
      >
      > open("/usr/lib/perl5/auto/Crypt/SSLeay/SSLeay.so", O_RDONLY) = -1 EACCES (Permission denied)
      >
    • Byrne Reese
      Ok folks - I am in need of a little help. Before I bang my head against the keyboard one last time, I thought I might consult my follow perl hackers for some
      Message 2 of 4 , Apr 6 1:17 PM
      • 0 Attachment
        Ok folks - I am in need of a little help. Before I bang my head against
        the keyboard one last time, I thought I might consult my follow perl
        hackers for some advice.

        I upgraded majordojo using RPMs to the latest Redhat 9 (yes I know
        support has been discontinued - thank you Redhat). In the process perl
        5.8.0 was installed... which naturally requires me to upgrade all my
        perl modules etc. So the state of my system, which was once Redhat 7.3
        running perl 5.6.1, is now running Redhat 9 (in theory), and perl 5.8.3
        (I upgraded from source to the latest hoping it would resolve my problem).

        Now, here is the problem:
        I have a CGI that makes a SOAP call, and when it does, I get the
        following message:
        > '501 Can't locate object method "new" via package
        "LWP::Protocol::https" (Crypt::SSLeay not installed) at browse.cgi line 61'

        But I have installed Crypt::SSLeay, lib-www, etc... I have installed all
        the necessary files. My proof?

        When I run the script from the command line as ROOT it works. Ok, so
        this naturally leads me to believe that I have a permissions problem.
        But where!? I have traversed the ENTIRE /usr/local/lib/perl5 directory
        heirarchy looking for permissions that are suspect, and every directory
        has the global execute bit set, every .so file has the global execute
        bit as well. Every file is globally readable. So what gives?

        I have since installed from source openssl-0.9.7d just to make sure.
        What am I missing here? This is killing me. I am running Redhat 9 at
        home, and everything works great. I am running Redhat 9 from the office,
        and everything is cool. Clearly something is not right with my RPM
        upgrade, but where do I start to track it down.

        Frustratingly Yours,
        Byrne
      • Byrne Reese
        Ok folks - I am in need of a little help. Before I bang my head against the keyboard one last time, I thought I might consult my follow perl hackers for some
        Message 3 of 4 , Apr 6 3:19 PM
        • 0 Attachment
          Ok folks - I am in need of a little help. Before I bang my head
          against the keyboard one last time, I thought I might consult my
          follow perl hackers for some advice.

          I upgraded majordojo using RPMs to the latest Redhat 9 (yes I know
          support has been discontinued - thank you Redhat). In the process
          perl 5.8.0 was installed... which naturally requires me to upgrade
          all my perl modules etc. So the state of my system, which was once
          Redhat 7.3 running perl 5.6.1, is now running Redhat 9 (in theory),
          and perl 5.8.3 (I upgraded from source to the latest hoping it would
          resolve my problem).

          Now, here is the problem:
          I have a CGI that makes a SOAP call, and when it does, I get the
          following message:
          > '501 Can't locate object method "new" via
          package "LWP::Protocol::https" (Crypt::SSLeay not installed) at
          browse.cgi line 61'

          But I have installed Crypt::SSLeay, lib-www, etc... I have installed
          all the necessary files. My proof?

          When I run the script from the command line as ROOT it works. Ok, so
          this naturally leads me to believe that I have a permissions problem.
          But where!? I have traversed the ENTIRE /usr/local/lib/perl5
          directory heirarchy looking for permissions that are suspect, and
          every directory has the global execute bit set, every .so file has
          the global execute bit as well. Every file is globally readable. So
          what gives?

          I have since installed from source openssl-0.9.7d just to make sure.
          What am I missing here? This is killing me. I am running Redhat 9 at
          home, and everything works great. I am running Redhat 9 from the
          office, and everything is cool. Clearly something is not right with
          my RPM upgrade, but where do I start to track it down.

          Frustratingly Yours,
          Byrne
        • Stephane Bortzmeyer
          On Tue, Apr 06, 2004 at 10:19:38PM -0000, Byrne Reese wrote ... RedHat, like FreeBSD, does not really support upgrades. It is probably
          Message 4 of 4 , Apr 7 12:14 AM
          • 0 Attachment
            On Tue, Apr 06, 2004 at 10:19:38PM -0000,
            Byrne Reese <byrne@...> wrote
            a message of 53 lines which said:

            > So the state of my system, which was once Redhat 7.3 running perl
            > 5.6.1, is now running Redhat 9 (in theory), and perl 5.8.3

            RedHat, like FreeBSD, does not really support upgrades. It is probably
            better to reinstall.

            > When I run the script from the command line as ROOT it works. Ok, so
            > this naturally leads me to believe that I have a permissions
            > problem. But where!?

            As non-root:

            % strace perl YOUR-SCRIPT.pl |& grep -i permission

            Should give you something like:

            open("/usr/lib/perl5/auto/Crypt/SSLeay/SSLeay.so", O_RDONLY) = -1 EACCES (Permission denied)
          Your message has been successfully submitted and would be delivered to recipients shortly.