Loading ...
Sorry, an error occurred while loading the content.

accept-encoding gzip

Expand Messages
  • c002928
    The web service I am using requires messages to have an http header that looks like this: Accept-Encoding: gzip, deflate or like this: Accept-Encoding: gzip I
    Message 1 of 2 , Feb 25, 2004
    • 0 Attachment
      The web service I am using requires messages to have an http header
      that looks like this:

      Accept-Encoding: gzip, deflate
      or like this:
      Accept-Encoding: gzip

      I added the following line to my client code

      -> proxy($endpoint, options => {compress_threshold => 10});

      I hoped this would add the http header but it only looks like this:

      Accept-Encoding: deflate

      so the request fails

      Is there a way to do this with SOAP::Lite without resorting to
      rolling your own POST message by adding headers and soap line by
      line?
    • Duncan Cameron
      ... From: c002928 To: Sent: Thursday, February 26, 2004 4:39 AM Subject: [soaplite] accept-encoding gzip
      Message 2 of 2 , Feb 26, 2004
      • 0 Attachment
        ----- Original Message -----
        From: "c002928" <scoldan@...>
        To: <soaplite@yahoogroups.com>
        Sent: Thursday, February 26, 2004 4:39 AM
        Subject: [soaplite] accept-encoding gzip


        > The web service I am using requires messages to have an http header
        > that looks like this:
        >
        > Accept-Encoding: gzip, deflate
        > or like this:
        > Accept-Encoding: gzip
        >
        > I added the following line to my client code
        >
        > -> proxy($endpoint, options => {compress_threshold => 10});
        >
        > I hoped this would add the http header but it only looks like this:
        >
        > Accept-Encoding: deflate
        >
        > so the request fails
        >
        > Is there a way to do this with SOAP::Lite without resorting to
        > rolling your own POST message by adding headers and soap line by
        > line?
        >
        From what I can see the only reason why the header would not be
        "Accept-Encoding: gzip" is if you do not have Compress::Zlib installed.
        The content of your message will then be gzipped if the length is
        greater than the threshold.
        Try stepping through SOAP/Transport/HTTP.pm from the start of the
        send_receive() routine to see where the problem is.
        If that doesn't clear it up then post a copy of your client code.

        Regards

        Duncan Cameron
      Your message has been successfully submitted and would be delivered to recipients shortly.