Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Forcing HTTP/1.1 for SOAP-Clients

Expand Messages
  • Duncan Cameron
    ... From: Zazie Queneau To: Sent: Monday, January 26, 2004 9:40 AM Subject: [soaplite] Forcing HTTP/1.1 for
    Message 1 of 2 , Jan 26, 2004
    • 0 Attachment
      ----- Original Message -----
      From: "Zazie Queneau" <zazie_6969@...>
      To: <soaplite@yahoogroups.com>
      Sent: Monday, January 26, 2004 9:40 AM
      Subject: [soaplite] Forcing HTTP/1.1 for SOAP-Clients


      > Hi there,
      >
      > there's a nice example for changing the HTTP protocol
      > in order to talk to servers that understand HTTP/1.1
      > only. I found it in the SOAP Cookbook on soaplite.com
      > (section 'Changing HTTP protocol')
      >
      > use SOAP::Lite +trace =>
      > transport => sub {
      > $_[0]->protocol('HTTP/1.1') if
      > $_[0]->isa('HTTP::Request')
      > };
      >
      > If I do so, it doesn't work and the perl (-w)
      > interpeter complains about "Odd (wrong?) number of
      > parameters in import(), still continue at ..."
      > Any idea what's wrong?
      The example has incorrect syntax, see this earlier message
      http://groups.yahoo.com/group/soaplite/message/1741

      Please can someone fix the example?
      Regards

      Duncan
    Your message has been successfully submitted and would be delivered to recipients shortly.