Loading ...
Sorry, an error occurred while loading the content.

Multipart message

Expand Messages
  • jigsaw9876
    Hi, I am trying to send a multipart message as per the example in MIME::Entity documentation from a soap server At my client, I get the following error: Can t
    Message 1 of 2 , Dec 18, 2003
    • 0 Attachment
      Hi,

      I am trying to send a multipart message as per the example in MIME::Entity
      documentation from a soap server
      At my client, I get the following error:
      Can't call method "as_string" on an undefined value at /Library/Perl/5.8.1/SOAP/
      Lite.pm line 1469.
      Which points to the line :

      push(@result, [$pid,$plocation,$type,$part->bodyhandle->as_string]);

      in decode_related sub.

      Can anyone throw some light on what is going wrong?

      Thanks,
      JS.
    • jigsaw9876
      Hi again, I have been sitting with this problem for a few days now and wonder if anyone has an idea? Has anyone tried this before? Any success? I understand
      Message 2 of 2 , Dec 22, 2003
      • 0 Attachment
        Hi again,

        I have been sitting with this problem for a few days now and wonder if anyone has
        an idea? Has anyone tried this before? Any success?

        I understand MIME::Entity->attach would create a multipart message; and a multipart/
        * message has no bodyhandle. And the error I get looks like this:

        Can't call method "as_string" on an undefined value at /Library/Perl/5.8.1/SOAP/
        Lite.pm line 1469 which points to
        push(@result, [$pid,$plocation,$type,$part->bodyhandle->as_string]) in sub
        decode_related

        Would really appreciate some help.

        Thanks,
        JS
      Your message has been successfully submitted and would be delivered to recipients shortly.