Loading ...
Sorry, an error occurred while loading the content.

What am I doing wrong?

Expand Messages
  • alpark444
    I ve got a simple cgi server with client running like one of the examples in a tutorial, however, it doesn t print the return. I tried the +trace= all option
    Message 1 of 2 , Sep 12, 2003
    • 0 Attachment
      I've got a simple cgi server with client running like one of the
      examples in a tutorial, however, it doesn't print the return.

      I tried the +trace=>all option and I can see the output between tags.
      Is there something that I forgot to do?

      SOAP::Transport::new: ()
      SOAP::Serializer::new: ()
      SOAP::Deserializer::new: ()
      SOAP::Parser::new: ()
      SOAP::Lite::new: ()
      SOAP::Transport::HTTP::Client::new: ()
      SOAP::Lite::call: ()
      SOAP::Serializer::envelope: ()
      SOAP::Serializer::envelope: hi
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Data::new: ()
      SOAP::Transport::HTTP::Client::send_receive: HTTP::Request=HASH(0x831b3ac)
      SOAP::Transport::HTTP::Client::send_receive: POST
      http://www.somewhere.com/cgi-bin/hibye.cgi
      Accept: text/xml
      Accept: multipart/*
      Content-Length: 446
      Content-Type: text/xml; charset=utf-8
      SOAPAction: "http://www.somewhere.com/Demo#hi"

      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:hi
      xmlns:namesp1="http://www.somewhere.com/Demo"/></SOAP-ENV:Body></SOAP-ENV:Envelope>
      SOAP::Transport::HTTP::Client::send_receive:
      HTTP::Response=HASH(0x848c520)
      SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
      Connection: close
      Date: Fri, 12 Sep 2003 17:24:20 GMT
      Server: Apache/2.0.40 (Red Hat Linux)
      Content-Length: 531
      Content-Type: text/xml; charset=utf-8
      Client-Date: Fri, 12 Sep 2003 17:24:20 GMT
      Client-Peer: 10.100.2.178:80
      Client-Response-Num: 1
      SOAPServer: SOAP::Lite/Perl/0.55

      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/1999/XMLSchema"
      SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:hiResponse
      xmlns:namesp1="http://www.somewhere.com/Demo"><s-gensym3
      xsi:type="xsd:string">hello,
      world</s-gensym3></namesp1:hiResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>
      SOAP::Deserializer::deserialize: ()
      SOAP::Parser::decode: ()
      SOAP::SOM::new: ()
      SOAP::Lite::DESTROY: ()
      SOAP::Deserializer::DESTROY: ()
      SOAP::Parser::DESTROY: ()
      SOAP::Transport::DESTROY: ()
      SOAP::Transport::HTTP::Client::DESTROY: ()
      SOAP::Serializer::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::Data::DESTROY: ()
      SOAP::SOM::DESTROY: ()
    • Byrne Reese
      It is hard to say if you are doing anything wrong without seeing the client code. :) Send that along and I will let you know. ... -- Byrne Reese
      Message 2 of 2 , Sep 18, 2003
      • 0 Attachment
        It is hard to say if you are doing anything wrong without seeing the
        client code. :)

        Send that along and I will let you know.

        On Fri, 2003-09-12 at 10:33, alpark444 wrote:
        > I've got a simple cgi server with client running like one of the
        > examples in a tutorial, however, it doesn't print the return.
        >
        > I tried the +trace=>all option and I can see the output between tags.
        > Is there something that I forgot to do?
        >
        > SOAP::Transport::new: ()
        > SOAP::Serializer::new: ()
        > SOAP::Deserializer::new: ()
        > SOAP::Parser::new: ()
        > SOAP::Lite::new: ()
        > SOAP::Transport::HTTP::Client::new: ()
        > SOAP::Lite::call: ()
        > SOAP::Serializer::envelope: ()
        > SOAP::Serializer::envelope: hi
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Data::new: ()
        > SOAP::Transport::HTTP::Client::send_receive:
        > HTTP::Request=HASH(0x831b3ac)
        > SOAP::Transport::HTTP::Client::send_receive: POST
        > http://www.somewhere.com/cgi-bin/hibye.cgi
        > Accept: text/xml
        > Accept: multipart/*
        > Content-Length: 446
        > Content-Type: text/xml; charset=utf-8
        > SOAPAction: "http://www.somewhere.com/Demo#hi"
        >
        > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
        > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
        > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
        > xmlns:xsd="http://www.w3.org/1999/XMLSchema"
        > SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:hi
        > xmlns:namesp1="http://www.somewhere.com/Demo"/></SOAP-ENV:Body></SOAP-ENV:Envelope>
        > SOAP::Transport::HTTP::Client::send_receive:
        > HTTP::Response=HASH(0x848c520)
        > SOAP::Transport::HTTP::Client::send_receive: HTTP/1.1 200 OK
        > Connection: close
        > Date: Fri, 12 Sep 2003 17:24:20 GMT
        > Server: Apache/2.0.40 (Red Hat Linux)
        > Content-Length: 531
        > Content-Type: text/xml; charset=utf-8
        > Client-Date: Fri, 12 Sep 2003 17:24:20 GMT
        > Client-Peer: 10.100.2.178:80
        > Client-Response-Num: 1
        > SOAPServer: SOAP::Lite/Perl/0.55
        >
        > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
        > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
        > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
        > xmlns:xsd="http://www.w3.org/1999/XMLSchema"
        > SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><namesp1:hiResponse
        > xmlns:namesp1="http://www.somewhere.com/Demo"><s-gensym3
        > xsi:type="xsd:string">hello,
        > world</s-gensym3></namesp1:hiResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>
        > SOAP::Deserializer::deserialize: ()
        > SOAP::Parser::decode: ()
        > SOAP::SOM::new: ()
        > SOAP::Lite::DESTROY: ()
        > SOAP::Deserializer::DESTROY: ()
        > SOAP::Parser::DESTROY: ()
        > SOAP::Transport::DESTROY: ()
        > SOAP::Transport::HTTP::Client::DESTROY: ()
        > SOAP::Serializer::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::Data::DESTROY: ()
        > SOAP::SOM::DESTROY: ()
        >
        >
        >
        > Yahoo! Groups Sponsor
        > ADVERTISEMENT
        > Click to learn more...
        >
        > To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        --
        Byrne Reese <byrne@...>
      Your message has been successfully submitted and would be delivered to recipients shortly.