Loading ...
Sorry, an error occurred while loading the content.

SoapLite and webservices ?

Expand Messages
  • Yahn Teisseire
    Hi, I m new with SOAP Lite and have a problem to use it with Web Services. I tried to make this :
    Message 1 of 2 , Mar 5, 2003
    • 0 Attachment
      Hi,
      I'm new with SOAP Lite and have a problem to use it with Web Services.
      I tried to make this :

      <

      SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

      <SOAP-ENV:Body>

      <m:createUser xmlns:m=http://myHost/UserManagement>

      <aUserLogin xsi:type="xsd:string">John</aUserLogin>

      <aUserPassword xsi:type="xsd:string">John007</aUserPassword>

      <aUserEmail xsi:type="xsd:string">john@...</aUserEmail>

      </m:createUser>

      </SOAP-ENV:Body>

      </SOAP-ENV:Envelope>

       

      Using this perl code :

      # -----------------------------------------------------------------

      use SOAP::Lite;

      use SOAP::Transport::HTTP;

       

      my $service = SOAP::Lite

            ->service(http://myHost/UserManagement?wsdl);

      my $result = $service->createUser(

      SOAP::Data->name("aUserLogin" => "john"),

      SOAP::Data->name("aUserPassword" => "John007"),

      SOAP::Data->name("aUserEmail" => "john\@..."));

      # -----------------------------------------------------------------

      And it doesn't works, i have Axix faults...

       

      Could you help me to find what's wrong ?

      Thanks to all

      __________________________________________________________________
      Yahn Teisseire
      Software Engineer

      Ukibi Inc.
      http://www.ukibi.com __________________________________________________________________

    • Martin Hajduch
      ... how does wsdl for your service look like ? ... how does axis fault look like ? regards, martin
      Message 2 of 2 , Mar 5, 2003
      • 0 Attachment
        > I'm new with SOAP Lite and have a problem to use it with Web Services.
        > I tried to make this :

        how does wsdl for your service look like ?

        > And it doesn't works, i have Axix faults...

        how does axis fault look like ?

        regards,
        martin
      Your message has been successfully submitted and would be delivered to recipients shortly.