Loading ...
Sorry, an error occurred while loading the content.

Basic authentication problem

Expand Messages
  • wilday8 <wilday8@yahoo.co.in>
    I have protected folder skyris using http access. For some reason the client bypasses the protection and can access the folder directly !!! Which means I can
    Message 1 of 1 , Feb 12, 2003
    • 0 Attachment
      I have protected folder skyris using http access. For some reason
      the client bypasses the protection and can access the folder
      directly !!! Which means I can run any script though I have
      protected that folder with http access.

      When I try accessing the folder using browser it asks for
      authentication !! So the problem exists only when accessing from
      the client code.

      Is there any configuration that I need to do while on the server
      for SOAP::Lite ?

      My Client code is

      ------------

      #!/usr/bin/perl
      use SOAP::Lite +autodispatch =>
      uri => 'http://optimistix.liqwidkrystal.com/Demo',
      proxy => 'https://optimistix.liqwidkrystal.com/skyris/hibye.cgi',
      on_fault => sub { my($soap, $res) = @_;
      die ref $res ? $res->faultstring : $soap->transport-
      >status, "\n";
      }
      ;
      print hi();

      ---------------

      If I replace the uri and proxy with something like this

      -----------------

      #!/usr/bin/perl

      use SOAP::Lite +autodispatch =>
      uri => 'http://www.soaplite.com/My/Examples',
      proxy => 'http://services.soaplite.com/auth/examples.cgi',
      on_fault => sub { my($soap, $res) = @_;
      die ref $res ? $res->faultstring : $soap->transport-
      >status, "\n";
      }
      ;

      print getStateName(21);

      --------------------

      I get a 401 authentication error which is as expected.
      So why is my code(case 1) not giving the same error ??


      thanks in advance,
      ashwinee kumar
    Your message has been successfully submitted and would be delivered to recipients shortly.