Loading ...
Sorry, an error occurred while loading the content.

SOAP mod_perl server is dying with signal 11...

Expand Messages
  • Tom Samplonius
    I just installed Apache 1.3.27 and mod_perl 1.27 with perl 5.8.0. I also installed expat 1.95.6. This is on FreeBSD 4.7. I installed all the associated Perl
    Message 1 of 2 , Feb 11, 2003
    • 0 Attachment
      I just installed Apache 1.3.27 and mod_perl 1.27 with perl 5.8.0. I also
      installed expat 1.95.6. This is on FreeBSD 4.7.

      I installed all the associated Perl packages with CPAN.

      I put the following into httpd.conf:

      <Location /soap>
      SetHandler perl-script
      PerlHandler Apache::SOAP
      PerlSetVar dispatch_to "/home/tom/perl/"
      </Location>

      And started Apache. Everything seems ok.

      I wrote the following server (basically copied from the website) and saved it
      as Test.pm in /home/tom/perl/:

      package Test;

      sub hi {
      return "hello, world";
      }

      sub bye {
      return "goodbye, cruel world";
      }


      I wrote the following client:

      #! /usr/bin/perl -w

      use SOAP::Lite;

      print SOAP::Lite
      -> uri('http://localhost/')
      -> proxy('http://localhost/soap')
      -> hi()
      -> result;


      When the client is executed, it produces the following output:

      Unexpected Content-Type '' returned

      And the Apache error_log indicates that one of its children exited with signal
      11.


      Any idea what is wrong? I'm guessing it is conflict, perhaps with Perl
      or expat. I had assumed that Perl 5.8.0 would be best, because of its Unicode
      support, or maybe expat 1.95 is a problem... What version of Perl and expat is
      recommended?


      Tom
    • severanrault <severanrault@yahoo.fr>
      Tom, I just want to share my experience with you. It seams that there is quite some porblems with perl5.8 and SOAP Lite (perl 5.8 has some bugs...) I have
      Message 2 of 2 , Feb 11, 2003
      • 0 Attachment
        Tom,

        I just want to share my experience with you.
        It seams that there is quite some porblems with perl5.8 and SOAP Lite
        (perl 5.8 has some bugs...) I have tried to basically do the exact
        smae thing as you but failed also (all I manage to do is a CGI
        server...) I subjest you use 5.6.1 instead

        severan
        --- In soaplite@yahoogroups.com, Tom Samplonius <tom@u...> wrote:
        >
        > I just installed Apache 1.3.27 and mod_perl 1.27 with perl
        5.8.0. I also
        > installed expat 1.95.6. This is on FreeBSD 4.7.
        >
        > I installed all the associated Perl packages with CPAN.
        >
        > I put the following into httpd.conf:
        >
        > <Location /soap>
        > SetHandler perl-script
        > PerlHandler Apache::SOAP
        > PerlSetVar dispatch_to "/home/tom/perl/"
        > </Location>
        >
        > And started Apache. Everything seems ok.
        >
        > I wrote the following server (basically copied from the website)
        and saved it
        > as Test.pm in /home/tom/perl/:
        >
        > package Test;
        >
        > sub hi {
        > return "hello, world";
        > }
        >
        > sub bye {
        > return "goodbye, cruel world";
        > }
        >
        >
        > I wrote the following client:
        >
        > #! /usr/bin/perl -w
        >
        > use SOAP::Lite;
        >
        > print SOAP::Lite
        > -> uri('http://localhost/')
        > -> proxy('http://localhost/soap')
        > -> hi()
        > -> result;
        >
        >
        > When the client is executed, it produces the following output:
        >
        > Unexpected Content-Type '' returned
        >
        > And the Apache error_log indicates that one of its children
        exited with signal
        > 11.
        >
        >
        > Any idea what is wrong? I'm guessing it is conflict, perhaps
        with Perl
        > or expat. I had assumed that Perl 5.8.0 would be best, because of
        its Unicode
        > support, or maybe expat 1.95 is a problem... What version of Perl
        and expat is
        > recommended?
        >
        >
        > Tom
      Your message has been successfully submitted and would be delivered to recipients shortly.