Loading ...
Sorry, an error occurred while loading the content.

Unsupported protocol HTTP

Expand Messages
  • Martin Keller
    Hi list, yesterday I bought the O Reilley Book Web Services with Perl from Ray/Kulchenko. I am a newbie and was suprised how easy web services can be when I
    Message 1 of 2 , Feb 9, 2003
    • 0 Attachment
      Hi list,

      yesterday I bought the O'Reilley Book "Web Services
      with Perl" from
      Ray/Kulchenko. I am a newbie and was suprised how easy
      web services can be
      when I saw at the sixth page a script using XMLRPC. I
      downloaded the needed
      modules and started the script. The script uses
      XMLRPC::Lite which in turn
      uses SOAP::Lite.
      Now reality faces me with error message "Unsupported
      protocol 'HTTP'".
      I have the hope that this is a typical newbie problem
      and there is just
      something wrong with my setup. Only found hints in the
      list concerning MAILTO

      I use Win98 with AOL 5.0. - ok ok not the up
      to date environment but I dont see any reason why it
      should not work, since I
      can ping www.oreillynet.com defined as the
      client-proxy. Attachment contains
      the script.

      Any help appreciated

      Martin



      __________________________________________________________________

      Gesendet von Yahoo! Mail - http://mail.yahoo.de
      Bis zu 100 MB Speicher bei http://premiummail.yahoo.de
    • Randy J. Ray
      ... Paul and I thank you. :-) ... Do you have the LWP (aka libwww-perl) package installed? I don t remember if SOAP::Lite requires it for installation, or just
      Message 2 of 2 , Feb 9, 2003
      • 0 Attachment
        > yesterday I bought the O'Reilley Book "Web Services
        > with Perl" from
        > Ray/Kulchenko. I am a newbie and was suprised how easy
        > web services can be

        Paul and I thank you. :-)

        > Now reality faces me with error message "Unsupported
        > protocol 'HTTP'".
        > I have the hope that this is a typical newbie problem
        > and there is just
        > something wrong with my setup. Only found hints in the
        > list concerning MAILTO

        Do you have the LWP (aka libwww-perl) package installed? I don't remember if
        SOAP::Lite requires it for installation, or just encourages it. But it is
        needed to provide the HTTP transport layer.

        Try installing LWP (and the support libs it needs) and trying the script
        again. I don't know if you're using the ActiveState Perl distribution and
        installer, but they have packages for all the parts you need.

        Randy
        --
        """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
        Randy J. Ray Campbell, CA http://www.rjray.org rjray@...

        Silicon Valley Scale Modelers: http://www.svsm.org
      Your message has been successfully submitted and would be delivered to recipients shortly.