Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] COM Interface Problems with https protocol

Expand Messages
  • Paul Kulchenko
    Hi Ulrich, ... That actually shouldn t happen, because Crypt/SSLeay/SSLeay.dll is included in Lite.dll. I believe I ve tested standalone module with https
    Message 1 of 2 , Dec 8, 2002
    • 0 Attachment
      Hi Ulrich,

      > the Lite.dll seems to be required. But wouldn't I need in addition
      > the SSL
      > libraries (openssl or similar) or does Win2K provides an
      > implementation for
      > these libs ?
      That actually shouldn't happen, because Crypt/SSLeay/SSLeay.dll is
      included in Lite.dll. I believe I've tested standalone module with
      https transport. It's also possible that you're using some of the
      options that I haven't tried and MainContext module is required for
      those options, but haven't been included. You may either make this
      module available somewhere in @INC, or generate Lite.dll yourself and
      include all libraries you need (all scripts/batch files are available
      in /examples/COM directory, but you'll need to use commercial PDK
      from ActiveState). I'll make sure that this file will be included in
      future versions of Lite.dll. Do you have any script I can test with?

      Best wishes, Paul.

      --- Ulrich Harttig <ulrich.harttig@...> wrote:
      > Hi all,
      >
      > I'm trying to use the SOAP::Lite COM Interface for calling a SOAP
      > server from
      > a VBA program under Win 2K (no Perl installed). After downloading
      > and
      > registration of the static COM Lite.dll, contacting a SOAP server
      > using the
      > HTTP protocol worked fine.
      > But contacting a SOAP server using the HTTPS protocol leads to the
      > error:
      > "Can't locate Crypt/SSLeay/MainContext.pm in @INC (@INC ....)"
      > Checking the @INC directories,I found a Crytp/SSLeay.dll that seems
      > to
      > indicate that the appropriate module is actually there and should
      > have been
      > found.
      > Can someone point me to cause of the error message ?
      > Judging from the documentation for the COM interface only the
      > registration of
      > the Lite.dll seems to be required. But wouldn't I need in addition
      > the SSL
      > libraries (openssl or similar) or does Win2K provides an
      > implementation for
      > these libs ?
      >
      > Thanks for your help
      >
      > Ulrich Harttig
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      >
      > To unsubscribe from this group, send an email to:
      > soaplite-unsubscribe@yahoogroups.com
      >
      >
      >
      > Your use of Yahoo! Groups is subject to
      > http://docs.yahoo.com/info/terms/
      >
      >


      __________________________________________________
      Do you Yahoo!?
      Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
      http://mailplus.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.