Loading ...
Sorry, an error occurred while loading the content.

proxy: transport protocol not specified

Expand Messages
  • Andersson, Kimmo
    Hi ! First some background information. I am using SOAP::Lite from C++ in HP-UX environment. I have embedded the Perl interpreter into my C++ program but
    Message 1 of 1 , Nov 26, 2002
    • 0 Attachment
      Hi !

      First some background information. I am using SOAP::Lite from C++ in HP-UX
      environment. I have embedded the Perl interpreter into my C++ program but
      because of memory consumption problems I have to find another solution. I
      have an intermediary Perl script which is called from C++ and which talks to
      SOAP::Lite.

      The solution is now try is to launch my intermediary Perl script with the
      system command from C++. But I ran to the following error which occurs when
      I use my application or if I run my Perl script from the command line. The
      error message is:
      Use of uninitialized value at
      /vobs/stage/p4cop/lib/perl5/site_perl/5.005/SOAP/Lite.pm line 374.
      proxy: transport protocol not specified

      I found one thread about a same kind of problem and I tried to follow the
      given instructions but to no avail. The embedded solution worked fine but
      not this one. I haven't changed my Perl script so much. It goes like this
      use SOAP::Lite;
      ....
      my ($soapClient) = SOAP::Lite
      -> autotype(0)
      -> uri('Some uri')
      -> proxy('Some proxy')
      ....

      I tried defining uri and proxy before use SOAP::Lite but that did not help.
      A BEGIN block has been also tried and neither did eval help.

      More than puzzled

      Kimmo Andersson

      Yomi Solutions Ltd E-mail: Kimmo.Andersson@....O
      Box 354, Piippukatu 11 Mobile: +358 50 384 3734
      FIN-40101 JYVÄSKYLÄ Fax : +358 14 240 4709FINLAND
    Your message has been successfully submitted and would be delivered to recipients shortly.