Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Using SOAP::Lite with HTTPS

Expand Messages
  • Byrne Reese
    The SOAP::Lite cookbook is correct on this one! :) You are correct - just replace the http:// with https:// for the proxy() method. At least this works for me.
    Message 1 of 4 , Mar 22, 2002
    • 0 Attachment
      The SOAP::Lite cookbook is correct on this one! :)

      You are correct - just replace the http:// with https:// for the proxy()
      method. At least this works for me. :/

      However, it assumes you have everything installed correctly. It looks
      like to me that Crypt::SSLeay, libnet, openssl or some other modules
      were not completely installed... but then again I could be wrong.

      On Fri, 2002-03-22 at 01:10, ekw1 wrote: Hi,

      Can anyone point me to an example of using SOAP::Lite with HTTPS? I
      was hoping it was as simple as setting the proxy to an "https://"
      url, but i get this error in the server logs when I do that in my
      client code:

      501 Can't local object method "new" via package "LWP::Protocol::https"

      SSL is enabled on my webserver. What must be done on the SOAP::Lite
      client side?

      Thanks for any help.

      Eric



      Yahoo! Groups Sponsor
      ADVERTISEMENT


      To unsubscribe from this group, send an email to:
      soaplite-unsubscribe@yahoogroups.com



      Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

      --
      :/ byrne

      breese@...
      (415) 544-7732
    • Duncan Cameron
      ... If this error is being raised on the server then it means that LWP::Protocol::https is not on your path. How have you coded your SOAP::Lite server?
      Message 2 of 4 , Mar 22, 2002
      • 0 Attachment
        On 2002-03-22 ekw1 wrote:
        >Hi,
        >
        >Can anyone point me to an example of using SOAP::Lite with HTTPS? I
        >was hoping it was as simple as setting the proxy to an "https://"
        >url, but i get this error in the server logs when I do that in my
        >client code:
        >
        >501 Can't local object method "new" via package "LWP::Protocol::https"
        If this error is being raised on the server then it means that LWP::Protocol::https
        is not on your path.
        How have you coded your SOAP::Lite server?

        Regards,
        Duncan Cameron
      • ekw1
        Thanks to all that replied. I did need to install Crypt::SSLeay first. I found this out not 5 minutes after posting my message and went back deleted the
        Message 3 of 4 , Mar 22, 2002
        • 0 Attachment
          Thanks to all that replied. I did need to install Crypt::SSLeay
          first. I found this out not 5 minutes after posting my message and
          went back deleted the message, but I guess you all are really fast!
          =)

          --- In soaplite@y..., Duncan Cameron <dcameron@b...> wrote:
          > On 2002-03-22 ekw1 wrote:
          > >Hi,
          > >
          > >Can anyone point me to an example of using SOAP::Lite with HTTPS?
          I
          > >was hoping it was as simple as setting the proxy to an "https://"
          > >url, but i get this error in the server logs when I do that in my
          > >client code:
          > >
          > >501 Can't local object method "new" via
          package "LWP::Protocol::https"
          > If this error is being raised on the server then it means that
          LWP::Protocol::https
          > is not on your path.
          > How have you coded your SOAP::Lite server?
          >
          > Regards,
          > Duncan Cameron
        • Paul Kulchenko
          Hi, ekw! ... There is nothing specific. use https:// instead of http:// in your proxy() method and you re done. ... Crypt-SSLeay must be installed. Nothing
          Message 4 of 4 , Mar 22, 2002
          • 0 Attachment
            Hi, ekw!

            --- ekw1 <ekw1@...> wrote:
            > Can anyone point me to an example of using SOAP::Lite with HTTPS?
            There is nothing specific. use https:// instead of http:// in your
            proxy() method and you're done.

            > 501 Can't local object method "new" via package
            > "LWP::Protocol::https"
            >
            > SSL is enabled on my webserver. What must be done on the
            > SOAP::Lite client side?
            Crypt-SSLeay must be installed. Nothing else as far as I remember.
            Check SECURITY section in User GUide (http://guide.soaplite.com/)
            there are some examples.

            Best wishes, Paul.

            __________________________________________________
            Do You Yahoo!?
            Yahoo! Movies - coverage of the 74th Academy Awards´┐Ż
            http://movies.yahoo.com/
          Your message has been successfully submitted and would be delivered to recipients shortly.