Loading ...
Sorry, an error occurred while loading the content.

SOAP::Lite and OpenSSH?

Expand Messages
  • Daryl Williams
    folks, i am reposting this as it appears to have been lost on delivery. my apologies if you have received more than one... hello everybody, i am new to this
    Message 1 of 3 , Feb 21, 2002
    • 0 Attachment
      folks, i am reposting this as it appears to have been lost on delivery.
      my apologies if you have received more than one...

      hello everybody, i am new to this list and new to soap in general. if
      this is not the correct list for my question, i apologize in advance.
      rtfms are welcomed especially if they include a pointer to the fm.

      i have been playing with SOAP::Lite, and am now trying to install it
      with support for openssl. however, the install fails with the following
      error message: (i am installing from cpan)

      ------ error message ------
      Checking for OpenSSL-0.9.6c or newer...
      I could not find your OpenSSL in `-L/chinampa/opt/lib'
      ---- end error message -----

      i have configured/installed openssl-0.9.6c with the following options:
      ../config shared --prefix=/chinampa/opt
      --openssldir=/chinampa/opt/openssl-0.9.6c

      and the following libraries have been installed to /chinampa/opt/lib:
      libssl.so
      libssl.so.0
      libssl.so.0.9.6
      libssl.a
      libcrypto.so
      libcrypto.so.0
      libcrypto.so.0.9.6
      libcrypto.a

      this is all happening on a solaris8, ultra5. your help would be greatly
      appreciated. please reply directly, or cc me at daryl@...
      as i am not a subscriber to this list.

      tia,

      daryl
    • Duncan Cameron
      ... No, it wasn t lost. Just that nobody responded! ... The problem isn t with SOAP::Lite but with one of the prerequisite packages, probably Crypt::SSLeay. I
      Message 2 of 3 , Feb 21, 2002
      • 0 Attachment
        On 2002-02-21 Daryl Williams wrote:
        >folks, i am reposting this as it appears to have been lost on delivery.
        >my apologies if you have received more than one...

        No, it wasn't lost. Just that nobody responded!

        >hello everybody, i am new to this list and new to soap in general. if
        >this is not the correct list for my question, i apologize in advance.
        >rtfms are welcomed especially if they include a pointer to the fm.
        >
        >i have been playing with SOAP::Lite, and am now trying to install it
        >with support for openssl. however, the install fails with the following
        >error message: (i am installing from cpan)
        >
        >------ error message ------
        >Checking for OpenSSL-0.9.6c or newer...
        >I could not find your OpenSSL in `-L/chinampa/opt/lib'
        >---- end error message -----
        >
        >i have configured/installed openssl-0.9.6c with the following options:
        >.../config shared --prefix=/chinampa/opt
        >--openssldir=/chinampa/opt/openssl-0.9.6c
        >
        >and the following libraries have been installed to /chinampa/opt/lib:
        >libssl.so
        >libssl.so.0
        >libssl.so.0.9.6
        >libssl.a
        >libcrypto.so
        >libcrypto.so.0
        >libcrypto.so.0.9.6
        >libcrypto.a

        The problem isn't with SOAP::Lite but with one of the prerequisite
        packages, probably Crypt::SSLeay.

        I suggest that you install that package manually rather than
        automatically through CPAN. You might then be able to figure out why
        it might not be working. Also have a look at its makefile.pm and
        any README to see what they say about OpenSSL.
        >
        >this is all happening on a solaris8, ultra5. your help would be greatly
        >appreciated. please reply directly, or cc me at daryl@...
        >as i am not a subscriber to this list.
        >
        If you're not a subscriber how are you posting to the list?

        Regards,
        Duncan Cameron
      • Daryl Williams
        hi duncan, thanks for your reply.i should have checked the cpan output closer. i have gotten past the issue with openssl and am now having fun with a compile
        Message 3 of 3 , Feb 21, 2002
        • 0 Attachment
          hi duncan, thanks for your reply.i should have checked the cpan
          output closer. i have gotten past the issue with openssl and am
          now having fun with a compile time error from Net::SSLeay, which
          i will pursue tomorrow.thanks for your help. below are answers
          your questions.

          >>this is all happening on a solaris8, ultra5. your help would be greatly
          >>appreciated. please reply directly, or cc me at daryl@...
          >>as i am not a subscriber to this list.
          >
          >If you're not a subscriber how are you posting to the list?

          i had to subscribe. i thought i had removed that last line.

          >>folks, i am reposting this as it appears to have been lost on delivery.
          >>my apologies if you have received more than one...
          >
          >No, it wasn't lost. Just that nobody responded!

          i did not receive the first one, so i thought the subscribe request
          had not finished processing by the time i sent the 1st email.

          thanks again,

          daryl
        Your message has been successfully submitted and would be delivered to recipients shortly.