Loading ...
Sorry, an error occurred while loading the content.

Element '~:VehicleReg' can't be allowed in valid XML message. Died

Expand Messages
  • Chris Davies
    I have just upgraded from perl 5.00503 to 5.6.1, and in the process upgraded a load of the packages from CPAN (gory details available if required). I have a
    Message 1 of 2 , Jan 28, 2002
    • 0 Attachment
      I have just upgraded from perl 5.00503 to 5.6.1, and in the process upgraded
      a load of the packages from CPAN (gory details available if required).

      I have a SOAP::Lite client that works fine under perl 5.00503, but produces
      the following message when making a remote call to a SOAP server:

      Element '~:VehicleReg' can't be allowed in valid XML message. Died

      I do have an element named "~:VehicleReg" (i.e. element name qualified with
      "~" as per the SOAP::Lite compatibility recommendations for talking to MS
      .NET servers.)

      I've googled but to no avail. Any suggestions, please?

      Thanks,
      Chris
      --
      Chris Davies, Manheim Online
      Tel. 0113 393-2004 Fax. 0870 444-0482. Mobile 07778 199069
    • Paul Kulchenko
      Hi, Chris! ... This prefix was deprecated and dropped. I also updated documentation and examples when v0.50 was introduced. from README (INCOMPATIBILITIES
      Message 2 of 2 , Jan 28, 2002
      • 0 Attachment
        Hi, Chris!

        > I do have an element named "~:VehicleReg" (i.e. element name
        > qualified with
        > "~" as per the SOAP::Lite compatibility recommendations for talking
        > to MS .NET servers.)
        This prefix was deprecated and dropped. I also updated documentation
        and examples when v0.50 was introduced.

        from README (INCOMPATIBILITIES section):

        - dropped semi-documented '~' prefix (as in '~:element')
        This prefix was a mistake. Use '{namespace}element' syntax or
        combination of name/uri as in SOAP::Data->name(...)->uri(...).

        Let me know if you still have problems.

        Best wishes, Paul.

        --- Chris Davies <Chris.Davies@...> wrote:
        > I have just upgraded from perl 5.00503 to 5.6.1, and in the process
        > upgraded
        > a load of the packages from CPAN (gory details available if
        > required).
        >
        > I have a SOAP::Lite client that works fine under perl 5.00503, but
        > produces
        > the following message when making a remote call to a SOAP server:
        >
        > Element '~:VehicleReg' can't be allowed in valid XML message. Died
        >
        > I do have an element named "~:VehicleReg" (i.e. element name
        > qualified with
        > "~" as per the SOAP::Lite compatibility recommendations for talking
        > to MS
        > .NET servers.)
        >
        > I've googled but to no avail. Any suggestions, please?
        >
        > Thanks,
        > Chris
        > --
        > Chris Davies, Manheim Online
        > Tel. 0113 393-2004 Fax. 0870 444-0482. Mobile 07778 199069
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        >
        > To unsubscribe from this group, send an email to:
        > soaplite-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to
        > http://docs.yahoo.com/info/terms/
        >
        >


        __________________________________________________
        Do You Yahoo!?
        Great stuff seeking new owners in Yahoo! Auctions!
        http://auctions.yahoo.com
      Your message has been successfully submitted and would be delivered to recipients shortly.