Loading ...
Sorry, an error occurred while loading the content.

Something strange in the land of mod_perl

Expand Messages
  • marceusx
    While buidling a mod_perl SOAP::Lite application I ve noticed that SOAP::Lite doesn t appear to re-intialise it s namespace variables on each call. For
    Message 1 of 1 , Jan 20, 2002
    • 0 Attachment
      While buidling a mod_perl SOAP::Lite application I've noticed that
      SOAP::Lite doesn't appear to re-intialise it's namespace variables on
      each call. For example...

      When calling the SOAP server via a SOAP::Lite client I call the soap
      server via the namespace to http://www.bubba.org/Hello (this is not
      the actual namespace, but since it's just a test client I gave it
      random data), and later when calling the same server via a Javascript
      client we used a different namespace (http://ballmer/Hello).

      The second call to the soap server dies with the error Expected
      http://www.bubba.org/Hello recieved http://ballmer/Hello. If we
      restart the server in which case the second call (javascript client)
      works perfectly untill we run the SOAP::Lite client again.

      Since I have not seen anyone else mention this I assume it is normal
      behavior, what am I doing wrong? Should I be intializing my
      namespaces differently? How does this play out in the grand scheme of
      the universe?

      I am rather new to both mod_perl and SOAP so I apologize for my
      ignorance.

      -Chris
    Your message has been successfully submitted and would be delivered to recipients shortly.