Loading ...
Sorry, an error occurred while loading the content.

Re: [soaplite] Connection to SOAP::Transport::TCP using SSL

Expand Messages
  • Paul Kulchenko
    Hi, Chris! ... Should be enough to specify SSL_* parameters as additional parameters for proxy method: use SOAP::Lite +autodispatch = proxy = [ tcp://... ,
    Message 1 of 5 , Jan 4, 2002
    • 0 Attachment
      Hi, Chris!

      > Does anyone know how I would connect using autodispatch and
      > specifying the SSL parameters that would be needed?
      Should be enough to specify SSL_* parameters as additional parameters
      for proxy method:

      use SOAP::Lite +autodispatch =>
      proxy => ['tcp://...', SSL_use_cert => 1]
      ;

      To check you may add:

      print "SSL enabled\n" if SOAP::Lite->self->transport->SSL;

      Let me know if it doesn't work for you.

      Best wishes, Paul.

      --- churd6669 <churd@...> wrote:
      >
      > I have the server set up using:
      >
      > my $daemon = SOAP::Transport::TCP::Server
      > -> new(LocalAddr => 'blah.com', LocalPort => '6669', Listen => 5,
      > Reuse => 1, SSL_verify_mode => '0x00', SSL_server => 1,
      > SSL_use_cert => 1)
      > -> dispatch_to('Foo');
      >
      >
      > Does anyone know how I would connect using autodispatch and
      > specifying the SSL parameters that would be needed?
      >
      > Any help would be appreciated,
      > Chris Hurd



      __________________________________________________
      Do You Yahoo!?
      Send FREE video emails in Yahoo! Mail!
      http://promo.yahoo.com/videomail/
    • churd6669
      Paul, Just a short update of what I have done. I included the parameters as you suggested and when I attempted to run the script it went CPU bound and hung.
      Message 2 of 5 , Jan 5, 2002
      • 0 Attachment
        Paul,

        Just a short update of what I have done. I included the parameters
        as you suggested and when I attempted to run the script it went CPU
        bound and hung.

        If run the SOAP server and client successfully using
        SOAP::Transport::TCP without the SSL. I have also successfully
        run a server using IO::Socket::SSL with the same parameters as I
        am trying with the SOAP server:

        Server:
        (.... SSL_server => 1, SSL_use_cert => 1, SSL_verify_mode => 0x00)

        Client:
        (.... SSL_use_cert => 1, SSL_verify_mode => 1)

        Any suggestions?

        Thank you,
        Chris Hurd



        --- In soaplite@y..., Paul Kulchenko <paulclinger@y...> wrote:
        > Hi, Chris!
        >
        > > Does anyone know how I would connect using autodispatch and
        > > specifying the SSL parameters that would be needed?
        > Should be enough to specify SSL_* parameters as additional parameters
        > for proxy method:
        >
        > use SOAP::Lite +autodispatch =>
        > proxy => ['tcp://...', SSL_use_cert => 1]
        > ;
        >
        > To check you may add:
        >
        > print "SSL enabled\n" if SOAP::Lite->self->transport->SSL;
        >
        > Let me know if it doesn't work for you.
        >
        > Best wishes, Paul.
        >
        > --- churd6669 <churd@c...> wrote:
        > >
        > > I have the server set up using:
        > >
        > > my $daemon = SOAP::Transport::TCP::Server
        > > -> new(LocalAddr => 'blah.com', LocalPort => '6669', Listen => 5,
        > > Reuse => 1, SSL_verify_mode => '0x00', SSL_server => 1,
        > > SSL_use_cert => 1)
        > > -> dispatch_to('Foo');
        > >
        > >
        > > Does anyone know how I would connect using autodispatch and
        > > specifying the SSL parameters that would be needed?
        > >
        > > Any help would be appreciated,
        > > Chris Hurd
        >
        >
        >
        > __________________________________________________
        > Do You Yahoo!?
        > Send FREE video emails in Yahoo! Mail!
        > http://promo.yahoo.com/videomail/
      • churd6669
        I figured out the problem. In SOAP/Transport/TCP.pm there is no use IO::Socket::SSL; . Once I put that in...everything works. Chris Hurd
        Message 3 of 5 , Jan 5, 2002
        • 0 Attachment
          I figured out the problem.

          In SOAP/Transport/TCP.pm there is no 'use IO::Socket::SSL;'.
          Once I put that in...everything works.

          Chris Hurd



          --- In soaplite@y..., "churd6669" <churd@c...> wrote:
          > Paul,
          >
          > Just a short update of what I have done. I included the parameters
          > as you suggested and when I attempted to run the script it went CPU
          > bound and hung.
          >
          > If run the SOAP server and client successfully using
          > SOAP::Transport::TCP without the SSL. I have also successfully
          > run a server using IO::Socket::SSL with the same parameters as I
          > am trying with the SOAP server:
          >
          > Server:
          > (.... SSL_server => 1, SSL_use_cert => 1, SSL_verify_mode => 0x00)
          >
          > Client:
          > (.... SSL_use_cert => 1, SSL_verify_mode => 1)
          >
          > Any suggestions?
          >
          > Thank you,
          > Chris Hurd
          >
          >
          >
          > --- In soaplite@y..., Paul Kulchenko <paulclinger@y...> wrote:
          > > Hi, Chris!
          > >
          > > > Does anyone know how I would connect using autodispatch and
          > > > specifying the SSL parameters that would be needed?
          > > Should be enough to specify SSL_* parameters as additional parameters
          > > for proxy method:
          > >
          > > use SOAP::Lite +autodispatch =>
          > > proxy => ['tcp://...', SSL_use_cert => 1]
          > > ;
          > >
          > > To check you may add:
          > >
          > > print "SSL enabled\n" if SOAP::Lite->self->transport->SSL;
          > >
          > > Let me know if it doesn't work for you.
          > >
          > > Best wishes, Paul.
          > >
          > > --- churd6669 <churd@c...> wrote:
          > > >
          > > > I have the server set up using:
          > > >
          > > > my $daemon = SOAP::Transport::TCP::Server
          > > > -> new(LocalAddr => 'blah.com', LocalPort => '6669', Listen => 5,
          > > > Reuse => 1, SSL_verify_mode => '0x00', SSL_server => 1,
          > > > SSL_use_cert => 1)
          > > > -> dispatch_to('Foo');
          > > >
          > > >
          > > > Does anyone know how I would connect using autodispatch and
          > > > specifying the SSL parameters that would be needed?
          > > >
          > > > Any help would be appreciated,
          > > > Chris Hurd
          > >
          > >
          > >
          > > __________________________________________________
          > > Do You Yahoo!?
          > > Send FREE video emails in Yahoo! Mail!
          > > http://promo.yahoo.com/videomail/
        • Paul Kulchenko
          Hi, Chris! You re right. Server side loads IO::Socket::SSL if it isn t loaded, but client side doesn t, so you need to that manually. It tries to autodispatch
          Message 4 of 5 , Jan 5, 2002
          • 0 Attachment
            Hi, Chris!

            You're right. Server side loads IO::Socket::SSL if it isn't loaded,
            but client side doesn't, so you need to that manually. It tries to
            autodispatch unresolved method again, hence looks like it hangs.
            Fixed. Thanks.

            Best wishes, Paul.

            --- churd6669 <churd@...> wrote:
            > I figured out the problem.
            >
            > In SOAP/Transport/TCP.pm there is no 'use IO::Socket::SSL;'.
            > Once I put that in...everything works.
            >
            > Chris Hurd
            >
            >
            >
            > --- In soaplite@y..., "churd6669" <churd@c...> wrote:
            > > Paul,
            > >
            > > Just a short update of what I have done. I included the
            > parameters
            > > as you suggested and when I attempted to run the script it went
            > CPU
            > > bound and hung.
            > >
            > > If run the SOAP server and client successfully using
            > > SOAP::Transport::TCP without the SSL. I have also successfully
            > > run a server using IO::Socket::SSL with the same parameters as I
            > > am trying with the SOAP server:
            > >
            > > Server:
            > > (.... SSL_server => 1, SSL_use_cert => 1, SSL_verify_mode =>
            > 0x00)
            > >
            > > Client:
            > > (.... SSL_use_cert => 1, SSL_verify_mode => 1)
            > >
            > > Any suggestions?
            > >
            > > Thank you,
            > > Chris Hurd
            > >
            > >
            > >
            > > --- In soaplite@y..., Paul Kulchenko <paulclinger@y...> wrote:
            > > > Hi, Chris!
            > > >
            > > > > Does anyone know how I would connect using autodispatch and
            > > > > specifying the SSL parameters that would be needed?
            > > > Should be enough to specify SSL_* parameters as additional
            > parameters
            > > > for proxy method:
            > > >
            > > > use SOAP::Lite +autodispatch =>
            > > > proxy => ['tcp://...', SSL_use_cert => 1]
            > > > ;
            > > >
            > > > To check you may add:
            > > >
            > > > print "SSL enabled\n" if SOAP::Lite->self->transport->SSL;
            > > >
            > > > Let me know if it doesn't work for you.
            > > >
            > > > Best wishes, Paul.
            > > >
            > > > --- churd6669 <churd@c...> wrote:
            > > > >
            > > > > I have the server set up using:
            > > > >
            > > > > my $daemon = SOAP::Transport::TCP::Server
            > > > > -> new(LocalAddr => 'blah.com', LocalPort => '6669', Listen
            > => 5,
            > > > > Reuse => 1, SSL_verify_mode => '0x00', SSL_server => 1,
            >
            > > > > SSL_use_cert => 1)
            > > > > -> dispatch_to('Foo');
            > > > >
            > > > >
            > > > > Does anyone know how I would connect using autodispatch and
            > > > > specifying the SSL parameters that would be needed?
            > > > >
            > > > > Any help would be appreciated,
            > > > > Chris Hurd
            > > >
            > > >
            > > >
            > > > __________________________________________________
            > > > Do You Yahoo!?
            > > > Send FREE video emails in Yahoo! Mail!
            > > > http://promo.yahoo.com/videomail/
            >
            >
            > ------------------------ Yahoo! Groups Sponsor
            >
            > To unsubscribe from this group, send an email to:
            > soaplite-unsubscribe@yahoogroups.com
            >
            >
            >
            > Your use of Yahoo! Groups is subject to
            > http://docs.yahoo.com/info/terms/
            >
            >


            __________________________________________________
            Do You Yahoo!?
            Send FREE video emails in Yahoo! Mail!
            http://promo.yahoo.com/videomail/
          Your message has been successfully submitted and would be delivered to recipients shortly.