Loading ...
Sorry, an error occurred while loading the content.

6202SOAP calls fail randomly

Expand Messages
  • bnyec
    Aug 22, 2008
    • 0 Attachment
      Apache/2.2.4
      mod_perl/2.0.3
      Perl/v5.8.8
      SOAP-Lite-0.710.08

      Ive noticed that sometimes my soap requests will fail every 6th
      request which is the same number of httpd children that are running.

      httpd.conf
      [....]

      <Location /soap>
      SetHandler perl-script
      PerlSendHeader On
      PerlHandler Apache::SOAP
      PerlSetVar dispatch_to "/path/to/modules"
      PerlSetVar options "compress_threshold => 10000"
      </Location>


      $ ps -auxx | grep httpd | wc -l
      6
      $ ./test-client.pl
      Resopnse: test
      $ ./test-client.pl
      Resopnse: test
      $ ./test-client.pl
      Resopnse: test
      $ ./test-client.pl
      Resopnse: test
      $ ./test-client.pl
      Resopnse: test
      $ ./test-client.pl
      <faultstring>Failed to locate method (my_meathod) in class (testing)
      at /usr/local/lib/perl5/site_perl/5.8.8/SOAP/Lite.pm line 2765.
      </faultstring>
      $ ./test-client.pl
      Resopnse: test

      [... next 5 and error occurs agian ...]


      Over on the perl.apache.org mailing list someone has had a similar
      problem, but hadn't seen what might be causing the problem.

      Further Details:
      http://marc.info/?l=apache-modperl&m=117759312529637&w=2

      Anyone have any idea's ??

      - B
    • Show all 3 messages in this topic