Loading ...
Sorry, an error occurred while loading the content.

6148RE: [soaplite] Install Problem

Expand Messages
  • Edward Kawas
    May 1, 2008
    • 0 Attachment

      Hi Andrew,

       

      I think that you need to install the ‘version’ module (http://search.cpan.org/~jpeacock/version-0.74/).

       

      Eddie

       

       

      From: soaplite@yahoogroups.com [mailto:soaplite@yahoogroups.com] On Behalf Of Andrew Berry
      Sent: May-01-08 3:35 AM
      To: soaplite@yahoogroups.com
      Subject: [soaplite] Install Problem

       

      All,

      I am hoping someone will be able to assit me, I am trying to install
      SOAP::Lite from the latest tarball I download. Perl version is 5.8.8,
      running on Ubuntu 6.10.

      After running "perl Makefile.PL", I press enter as instructed, press
      enter again to proceed and then get the following error:-

      local $VERSION;
      $VERSION=undef;
      do {
      use version; $VERSION = qv('0.71.04');
      };
      $VERSION;
      ' in lib/SOAP/Lite.pm: Can't locate version.pm in @INC (@INC
      contains: /etc/perl /usr/local/lib/perl/5.8.8
      /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
      /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl
      /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 .) at (eval 107)
      line 16, <$fh> line 22.
      BEGIN failed--compilation aborted at (eval 107) line 16, <$fh> line 22.
      WARNING: Setting VERSION via file 'lib/SOAP/Lite.pm' failed
      at /usr/local/share/perl/5.8.8/ExtUtils/MakeMaker.pm line 511
      Writing Makefile for SOAP::Lite

      I'm unsure how to resolve this issue and so far been unable to find
      any posts pointing me in the correct version.

      If I try and install from CPAN, I get the "don't know what it is"
      error message.

      Anyone able to point me in the correct direction?

      Thanks,

      Andrew

    • Show all 3 messages in this topic