Loading ...
Sorry, an error occurred while loading the content.

3610SOAP::Lite 0.60 - solaris 5.8 - timeouts

Expand Messages
  • rafiq.ismail@mail.ing.nl
    May 27, 2004
    • 0 Attachment
      SOAP::Lite 0.60 - solaris 5.8 - timeouts

      Dear All,

      I'm experiencing some weirdness with SOAP::Lite.  I'm running a c++ gsoap server, which has all connection timeouts disabled.  With this I'm also running a perlscript which opens a SOAP::Lite, huge timeout, connection to the given server, sends a request, gets back a result or fault string; the normal stuff.  Now on large requests which consume over 3 minutes on the server side it appears that the client frequently timesout at around 3.25 minutes.  It doesn't seem to matter how high I take the SOAP::lite timeout, whatever I do it seems to default to 3 minutes.  I'm at a total loss as to where I should go next and have not the time to trace this right back through the source. 

      I'd be super grateful to anyone who might be able to shed some light on tihs for me.  Any tips, suggestions or experiences would be appreciated.

      Thanks in Advance.
      Cheers,

      Raf



      -----------------------------------------------------------------
      ATTENTION:
      The information in this electronic mail message is private and
      confidential, and only intended for the addressee. Should you
      receive this message by mistake, you are hereby notified that
      any disclosure, reproduction, distribution or use of this
      message is strictly prohibited. Please inform the sender by
      reply transmission and delete the message without copying or
      opening it.

      Messages and attachments are scanned for all viruses known.
      If this message contains password-protected attachments, the
      files have NOT been scanned for viruses by the ING mail domain.
      Always scan attachments before opening them.
      -----------------------------------------------------------------