Loading ...
Sorry, an error occurred while loading the content.

3088Re: SOAP::Lite and attachments...

Expand Messages
  • jpeyser
    Oct 28, 2003
    • 0 Attachment
      Bill,
      You also need the SOAP-MIME package (I believe the latest
      version is SOAP-MIME-0.55-7). The SOAP-MIME package contains a
      directory of examples, including a client module and a server module.
      I had to modify both to get them to work. (This is not an Apache
      example.)

      Client Module compose.pl

      I had to change a couple of lines.

      my @parts = ($ent);

      my $som = SOAP::Lite
      ->readable(1)
      ->uri($SOME_NAMESPACE)
      ->proxy($SOME_HOST)
      # ->parts([ $ent ])
      ->parts(@parts)
      ->on_debug(sub {&My::Trace::defaultlog;})
      ->echo(SOAP::Data->name("whatToEcho" => "GREAT"));

      Server Module mime_server.cgi

      I modified the beginning including changing the server type from CGI
      to Daemon.

      use SOAP::Lite;
      use SOAP::MIME;
      use SOAP::Transport::HTTP;

      my $port = shift || 8765;

      my $daemon = SOAP::Transport::HTTP::Daemon
      -> new ('LocalPort' => $port, 'Reuse' => 1)
      -> dispatch_to('SOAP_MIME_Test')
      -> handle;

      Jonathan

      --- In soaplite@yahoogroups.com, bhess@t... wrote:
      > I am working with SOAP::Lite 0.60 which I obtained from SourceForge
      and cannot get MIME attachments to work properly. I have seen this
      topic on this list many times before but cannot find a COMPLETE AND
      WORKING example of how to do this from both client and server sides.
      Is this possible? If yes, can someone please submit an example. My
      server side is using Apache/mod_perl/mod_soap configuration...
      >
      > Thanks in advance...
      >
      > --
      >
      > Bill Hess
      > Technology Resource Group
    • Show all 12 messages in this topic