Loading ...
Sorry, an error occurred while loading the content.

2555Re: [soaplite] Problems with use

Expand Messages
  • Andre Bonhote
    Apr 29, 2003
    • 0 Attachment
      Hi Quinn

      Thanks for your response.

      On Wed, Apr 16, 2003 at 10:04:27PM -0700, Quinn Weaver wrote:
      > > Now, with "use RRDs" commented out, the client works fine and returns a
      > > big @INC. As soon as I uncomment this line, the client complains with
      > > "Can't locate RRDs.pm in @INC" (with +trace => qw(debug);)

      > Try including the module from your soap_startup.pl (if you use one) or
      > via a PerlRequire Apache directive. I don't if this is a DynaLoader
      > problem, but I've seen it before, and this approach fixed it for me.

      Ok, what I did now is write this into my .htaccess:

      PerlRequire Image/Magick.pm

      According to mod_perl(1) this should load the file from within @INC.
      Apache does not complain, so I suppose it gets loaded.

      Am I completely wrong when I think that when this is done, I don't need
      to do "use Image::Magick;" again inside my module? Well, anyway, I
      commented it out and tried to access some Magick-functions, without
      success. After that, I removed the comment and found the same error
      message (can't locate module ...).

      I am quite stuck here ... any hints?

      Thanks a lot in advance!

      André

      --
      Hope is a waking dream.
      -- Aristotle
    • Show all 5 messages in this topic