Loading ...
Sorry, an error occurred while loading the content.

1645Re: [soaplite] Jabber transport fails?

Expand Messages
  • Dougal Campbell
    Jun 25, 2002
    • 0 Attachment
      On Fri, 21 Jun 2002, Chris Davies wrote:

      > I'm experimenting with the jabber transport, SOAP::Transport::JABBER, and
      > trying to get a handle on what's going on.
      >
      > [....]
      >
      > Can't locate object method "AddDelegate" via package "Net::Jabber::Protocol"
      > (perhaps you forgot to load "Net::Jabber::Protocol"?) at
      > /usr/local/lib/perl5/site_perl/5.6.1/Net/Jabber/Client.pm line 171.
      >
      > [....]
      >
      > I'm reasonably sure my modules are uptodate (SOAP::Lite 0.55, Net::Jabber
      > et al from Net-Jabber-1.0024.tar.gz). Interestingly, if I grep for
      > AddDelegate in my installed perl tree I see it twice, only in
      > SOAP::Transport::JABBER.

      I had the same problem (about a month ago). It seems that the JABBER
      transport was written based on Net::Jabber 1.0021, and the AddDelegate
      stuff has been removed from the module since then.

      I think Paul Kulchenko said that he'd be updating SOAP::Lite to support
      the new Jabber modules, but didn't give a timeframe. I tried to find my
      copy of his message, but I can't remember where I filed it....

      If you haven't already, you might try asking on the Jabber-Dev mailing
      list, and see if somebody there has already rigged up something.

      --
      Ernest MacDougal Campbell III, MCP+I, MCSE <dougal@...>
      http://dougal.gunters.org/ http://spam.gunters.org/
      Web Design & Development: http://www.mentalcollective.com/
      This message is guaranteed to be 100% eror frea!
    • Show all 4 messages in this topic