Loading ...
Sorry, an error occurred while loading the content.

1091Re: [soaplite] Reference instead of NULL in .NET and SOAP::Lite Interop

Expand Messages
  • Vaibhav Arya
    Dec 11, 2001
    • 0 Attachment
      Hi Paul:

      Thanks for your help. The following is the Soap
      Request from the COM object using MS SOAP SDK

      (It seems like MS SOAP is sending an empty string
      instead of a null. Could that be the issue?)

      Request :
      Method POST
      Headers HTTP::Headers=HASH(0x82b8b04)
      Uri /cgi-bin/soap/soapserver.cgi

      Content :
      <?xml version="1.0" encoding="UTF-8"
      standalone="no"?><SOAP-ENV:Envelope
      SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"

      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
      <SOAP-ENV:Body>
      <SOAPSDK1:email xmlns:SOAPSDK1="Alert"><Alert/>
      <Admin>
      <adminID
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xsi:type="xsd:int">1</adminID>
      <siteID
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xsi:type="xsd:int">1</siteID>
      <SessionID
      xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
      xsi:type="xsd:float">1007796996303560.327407438614504</SessionID>
      </Admin>
      <values
      xmlns:SOAPSDK2="http://www.w3.org/2001/XMLSchema"
      xmlns:SOAPSDK3="http://schemas.xmlsoap.org/soap/encoding/"

      SOAPSDK3:arrayType="SOAPSDK2:anyType[10]"
      xmlns:SOAPSDK4="http://www.w3.org/2001/XMLSchema-instance"

      SOAPSDK4:type="SOAPSDK3:Array">
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">emailfrom</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">utsah@...</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">subject</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">email test12/8/01
      12:53:55 PM</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">plainemail</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string"></SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">htmlemail</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">PGh0bWw+PGJvZHk+dXRzYWggc2VuZCB0aGlzIHRvZGF5IDwvYm9keT48L2h0bWw+</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:string">emailretry</SOAPSDK3:anyType>
      <SOAPSDK3:anyType
      SOAPSDK4:type="SOAPSDK2:short">2</SOAPSDK3:anyType></values>
      </SOAPSDK1:email>
      </SOAP-ENV:Body>
      </SOAP-ENV:Envelope>


      Thanks again.


      Regards,
      Vaibhav Arya



      --- Paul Kulchenko <paulclinger@...> wrote:
      > Hi, Vaibhav!
      >
      > > The client is trying to call a function with one
      > of the parameters
      > > as
      > > NULL, however when the server recieves the call,
      > the Null param is
      > > not recieved as a null, rather as a Reference.
      > Would it be possible to post a request wiredump?
      > Thank you.
      >
      > Best wishes, Paul.
      >


      =====
      - Vaibhav Arya
      <vaibhav_arya@...>


      __________________________________________________
      Do You Yahoo!?
      Check out Yahoo! Shopping and Yahoo! Auctions for all of
      your unique holiday gifts! Buy at http://shopping.yahoo.com
      or bid at http://auctions.yahoo.com
    • Show all 4 messages in this topic