Loading ...
Sorry, an error occurred while loading the content.

1041unexpected EOF

Expand Messages
  • Eric Baller
    Nov 27, 2001
      I've been digging through the archive and this is the closest
      reference I can find.

      I'm also getting the same "unexpected EOF" errors but I don't own the
      server or the apache configuration.

      When I was on my own linux box, I was able to get everything I want
      to work properly (thanks to good documentation, support in this
      group, and some excellent software from Paul...)

      But when I move it up to my hosting company's machine (also linux), I
      get that "500..." error. I had to install a few modules since they
      didn't have SOAP::Lite or URI (I won't reveal who they are so as not
      to disgrace them ;^) but I got through that easy enough.

      Are there other approaches that might help besides asking them to
      change the apache configuration?

      Thanks,
      Eric

      --- In soaplite@y..., Paul Kulchenko <paulclinger@y...> wrote:
      > Hi, Juan!
      >
      > It might be this (documented in SOAP/Transport/HTTP.pm):
      >
      > =item Apache is crashing with segfaults
      >
      > If using SOAP::Lite (or XML::Parser::Expat) in combination with
      > mod_perl
      > causes random segmentation faults in httpd processes try to
      configure
      > Apache with:
      >
      > RULE_EXPAT=no
      >
      > See http://archive.covalent.net/modperl/2000/04/0185.xml for more
      > details and lot of thanks to Robert Barta (rho@b...) for
      > explaining this weird behavior.
      >
      > Hope it helps.
      >
      > Best wishes, Paul.
      >
      > --- Juan Julian Merelo Guervos <jmerelo@g...> wrote:
      > > Hi,
      > > I'm trying to use SOAP::Lite with Apache 1.3.20 and mod_perl
      1.25;
      > > SOAP::Lite version is 0.50. It coredumps with this simple setup:
      > >
      > > -- server
      > > #!/usr/bin/perl -w
      > >
      > > use SOAP::Transport::HTTP;
      > >
      > > SOAP::Transport::HTTP::CGI
      > > -> dispatch_to('Eval')
      > > -> handle;
      > >
      > > package Eval;
      > >
      > > sub test {
      > > my $class =shift;
      > > my $msg = shift;
      > > return "Hola $msg";
      > > }
      > > -- client
      > > #!/usr/bin/perl -w
      > >
      > > use SOAP::Lite;
      > >
      > > my $soapResponse=
      SOAP::Lite
      > >
      > > ->
      > > uri
      ('http://www.geneura.org/Eval')
      > >
      > > -> proxy("http://localhost:8080/perl/SOAPtest.pl")
      > > -> test( "Pepelillo");
      > >
      > > print $soapResponse->result;
      > >
      > > ---
      > > Apache config:
      > > Alias /perl/ /home/jmerelo/apache/perl/
      > > <Location /perl>
      > > SetHandler perl-script
      > > PerlHandler Apache::Registry
      > > #PerlModule CGI SOAP::Lite
      > > PerlSendHeader On
      > > Options +ExecCGI
      > > </Location>
      > > --
      > >
      > > It coredumps with this error:
      > >
      > > mercurio:~/progs/ga-xsl$ ./SOAPtestclient.pl
      > > 500 unexpected EOF before status line seen
      > > at ./SOAPtestclient.pl line 5
      > >
      > > Any idea?
      > >
      > > J
      > >
      > > --
      > > jmerelo@g... | jjmerelo@w...
      > > JJ Merelo | http://geneura.ugr.es/~jmerelo
      > > Grupo Geneura ---- Univ. Granada | http://www.geneura.org/
      > >
      > > To unsubscribe from this group, send an email to:
      > > soaplite-unsubscribe@y...
      > >
      > >
      > >
      > > Your use of Yahoo! Groups is subject to
      > > http://docs.yahoo.com/info/terms/
      > >
      > >
      >
      >
      > __________________________________________________
      > Do You Yahoo!?
      > Get personalized email addresses from Yahoo! Mail - only $35
      > a year! http://personal.mail.yahoo.com/
    • Show all 10 messages in this topic