Loading ...
Sorry, an error occurred while loading the content.

RE: [soapbuilders] Help urgent!

Expand Messages
  • Dinesh Shahane
    I am assuming that you want to escape the xml reserved characters. Use < and > or enclose the string in a CDATA section as
    Message 1 of 2 , Apr 21 11:44 PM
    • 0 Attachment
      I am assuming that you want to escape the xml reserved characters. Use &lt; and &gt; or enclose the string in a CDATA section as
      <in0 xsi:type="xsd:string"><![CDATA[
      <?xml version="1.0" encoding="utf-8" ?>
        <endUserAuthentication userid="kjhkhj" passwd="gsgjhgjh"/>
      ]]></in0>
       
       -----Original Message-----
      From: swatigore_99 [mailto:swatigore_99@...]
      Sent: Wednesday, April 21, 2004 11:33 PM
      To: soapbuilders@yahoogroups.com
      Subject: [soapbuilders] Help urgent!

      Hi,
      i want to send soap request to webservice in which ther is an
      argument String.But i need to pass an Xml format at that place so <
      or > signs are not giving proper response..How to handle it?
      here's the soap envelope:

      <SOAP-ENV:Envelope xmlns:SOAP-
      ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-
      ENC="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema">
            <SOAP-ENV:Body>
                  <m:endUserAuthentication xmlns:m="http://irctc" SOAP-
      ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
                        <in0 xsi:type="xsd:string">String</in0>
                  </m:endUserAuthentication>          |
            </SOAP-ENV:Body>                            |
                                                      (At this position)
      </SOAP-ENV:Envelope>                                |
                                                          |
                                     i want to write as
      <?xml version="1.0" encoding="utf-8" ?>
        <endUserAuthentication userid="kjhkhj" passwd="gsgjhgjh"/>

      so those < and > signs are making problem..how to overcome that?




      -----------------------------------------------------------------
      This group is a forum for builders of SOAP implementations to discuss implementation and interoperability issues.  Please stay on-topic.


    Your message has been successfully submitted and would be delivered to recipients shortly.