Loading ...
Sorry, an error occurred while loading the content.

No response from Java invoked from .Net

Expand Messages
  • andersson_christian
    Hi, I am quite new to web services and have encoutered a problem from .Net. I have built a web service from WSAD 4.05 (SOAP 2.3) that uses doc/lit. Because
    Message 1 of 1 , Jun 9, 2003
    View Source
    • 0 Attachment
      Hi,
      I am quite new to web services and have encoutered a problem
      from .Net.

      I have built a web service from WSAD 4.05 (SOAP 2.3) that uses
      doc/lit. Because there is no direct support for doc/lit in 4.xx I had
      to do a bit of tweeking to get it to work (half...).
      The steps I did was.
      1.Wrote an own proxy that calls "messagerouter"
      2.Wrote a "facade" that the proxy calls (SOAP Action)
      3.Modified dds.xml to include the "facade" and set id.

      The main function resides in an EJB and takes an org.w3c.XML Element
      as input and returns an org.w3c.XML Element.

      Now to the problem.
      From WSAD I wrote a test client, and that works fine. (Not from wsdl)
      But from .Net(c#) there is no response back. (From wsdl).
      I can see the request coming in from .Net and the EJB kicks in an
      processes the request, passes back a response to the "facade" but
      from there it's gone.

      A couple of things I noticed is.
      1. From JAVA I use http 1.0 from .Net it's 1.1 changed in browser not
      to use 1.1 but still it sends 1.1. How can I change to http 1.0 from
      1.1?
      2. When service i invoked from java I can see the there is a close
      and after thet I get the response, from .Net there is no close. Hov
      can I make a "hard" close from .Net.
      3. The requst in the SOAP:Body is identical from Java and .Net
      Is there a basic error I am doing?? I'm going nuts...

      Thanks,
      Christian
    Your message has been successfully submitted and would be delivered to recipients shortly.