Loading ...
Sorry, an error occurred while loading the content.

Remote SOAP messaging problem with SoapExtension

Expand Messages
  • Siddharth
    I am using a soapextension class to convert a multipart mime message to theform understandable to .NET . When I am using a client (which runs on the same
    Message 1 of 4 , Jun 6, 2003
    • 0 Attachment
      I am using a soapextension class to convert a multipart mime message to theform understandable to .NET .
      When I am using a client (which runs on the same machine as the webservice)to send a multipart MIME message to my webservice using this soap extesnion class everything works fine .
      However , if I deplay the same client on a different machine on the lan and which send the same multipart MIME message to the the Web-service then it no longer works .I get back an internal server error .
      The trace shows that the webservice is entering the GetInitializer() method and after that crashes .
      Could anybody tell me what the problem is and how do i solve it ?
      Thanks
      Siddharth
    • jhuang40
      Siddharth, Could you please share your knowledge on how to send multipart MIME message? Did you use Soap Toolkit 3.0? I could not find any function that allows
      Message 2 of 4 , Jul 15, 2003
      • 0 Attachment
        Siddharth,

        Could you please share your knowledge on how to send multipart MIME
        message? Did you use Soap Toolkit 3.0? I could not find any function
        that allows you to construct a multipart MIME message in MS Soap
        Toolkit 3.0.

        Also please post your sample code!

        thanks

        -john


        --- In soapbuilders@yahoogroups.com, "Siddharth" <sbhavsar@e...>
        wrote:
        > I am using a soapextension class to convert a multipart mime
        message to theform understandable to .NET .
        > When I am using a client (which runs on the same machine as the
        webservice)to send a multipart MIME message to my webservice using
        this soap extesnion class everything works fine .
        > However , if I deplay the same client on a different machine on the
        lan and which send the same multipart MIME message to the the Web-
        service then it no longer works .I get back an internal server error .
        > The trace shows that the webservice is entering the GetInitializer
        () method and after that crashes .
        > Could anybody tell me what the problem is and how do i solve it ?
        > Thanks
        > Siddharth
      • Siddharth
        Hi , I have not used any toolkit . What i did was to create a multipart mime message using xml serializer and stringbuilder to create my custom mime message as
        Message 3 of 4 , Jul 15, 2003
        • 0 Attachment
          Hi ,
          I have not used any toolkit .
          What i did was to create a multipart mime message using xml serializer and
          stringbuilder to create my custom mime message as per the mime specification
          .
          Then simply create
          HttpWebRequest object and set the headers and do a send and GetResponse()
          method calls .Then on the web- service side on sreceiving the message I
          remove the attachments by my custom parser by parsing the stream in the
          beforeDeserialize() method and then pass the main soap message w/o
          attachment to the .net framework .

          I cant provide the source code becos it's company confidential. I am sorry
          for that .

          Hope this helps

          Siddharth
          ----- Original Message -----
          From: jhuang40
          Sent: Tuesday, July 15, 2003 6:26 AM
          Subject: [soapbuilders] Re: Remote SOAP messaging problem with SoapExtension

          Siddharth,

          Could you please share your knowledge on how to send multipart MIME
          message? Did you use Soap Toolkit 3.0? I could not find any function
          that allows you to construct a multipart MIME message in MS Soap
          Toolkit 3.0.

          Also please post your sample code!

          thanks

          -john


          --- In soapbuilders@yahoogroups.com, "Siddharth" <sbhavsar@e...>
          wrote:
          > I am using a soapextension class to convert a multipart mime
          message to theform understandable to .NET .
          > When I am using a client (which runs on the same machine as the
          webservice)to send a multipart MIME message to my webservice using
          this soap extesnion class everything works fine .
          > However , if I deplay the same client on a different machine on the
          lan and which send the same multipart MIME message to the the Web-
          service then it no longer works .I get back an internal server error .
          > The trace shows that the webservice is entering the GetInitializer
          () method and after that crashes .
          > Could anybody tell me what the problem is and how do i solve it ?
          > Thanks
          > Siddharth



          -----------------------------------------------------------------
          This group is a forum for builders of SOAP implementations to discuss implementation and interoperability issues.  Please stay on-topic.

          To unsubscribe from this group, send an email to:
          soapbuilders-unsubscribe@yahoogroups.com



          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        • jhuang40
          Thanks Siddharth for sharing your experience. I now understand how you did (basically constructing MIME message yourslef). I was thinking that Microsoft might
          Message 4 of 4 , Jul 15, 2003
          • 0 Attachment
            Thanks Siddharth for sharing your experience. I now understand how
            you did (basically constructing MIME message yourslef). I was
            thinking that Microsoft might provide some SDKs or helper classes to
            handle MIME attachments easily but then I found that it only supports
            DIME attachments in SOAP Toolkit 3.0.

            You dont need to post sample code.

            Thanks

            -john


            --- In soapbuilders@yahoogroups.com, "Siddharth" <sbhavsar@e...>
            wrote:
            > Hi ,
            > I have not used any toolkit .
            > What i did was to create a multipart mime message using xml
            serializer and
            > stringbuilder to create my custom mime message as per the mime
            specification
            > .
            > Then simply create
            > HttpWebRequest object and set the headers and do a send and
            GetResponse()
            > method calls .Then on the web- service side on sreceiving the
            message I
            > remove the attachments by my custom parser by parsing the stream in
            the
            > beforeDeserialize() method and then pass the main soap message w/o
            > attachment to the .net framework .
            >
            > I cant provide the source code becos it's company confidential. I
            am sorry
            > for that .
            >
            > Hope this helps
            >
            > Siddharth
            >
            > ----- Original Message -----
            > From: jhuang40
            > To: soapbuilders@yahoogroups.com
            > Sent: Tuesday, July 15, 2003 6:26 AM
            > Subject: [soapbuilders] Re: Remote SOAP messaging problem with
            SoapExtension
            >
            >
            > Siddharth,
            >
            > Could you please share your knowledge on how to send multipart
            MIME
            > message? Did you use Soap Toolkit 3.0? I could not find any
            function
            > that allows you to construct a multipart MIME message in MS Soap
            > Toolkit 3.0.
            >
            > Also please post your sample code!
            >
            > thanks
            >
            > -john
            >
            >
            > --- In soapbuilders@yahoogroups.com, "Siddharth" <sbhavsar@e...>
            > wrote:
            > > I am using a soapextension class to convert a multipart mime
            > message to theform understandable to .NET .
            > > When I am using a client (which runs on the same machine as the
            > webservice)to send a multipart MIME message to my webservice
            using
            > this soap extesnion class everything works fine .
            > > However , if I deplay the same client on a different machine on
            the
            > lan and which send the same multipart MIME message to the the Web-
            > service then it no longer works .I get back an internal server
            error .
            > > The trace shows that the webservice is entering the
            GetInitializer
            > () method and after that crashes .
            > > Could anybody tell me what the problem is and how do i solve
            it ?
            > > Thanks
            > > Siddharth
            >
            >
            > Yahoo! Groups Sponsor
            > ADVERTISEMENT
            >
            >
            >
            >
            > -----------------------------------------------------------------
            > This group is a forum for builders of SOAP implementations to
            discuss implementation and interoperability issues. Please stay on-
            topic.
            >
            > To unsubscribe from this group, send an email to:
            > soapbuilders-unsubscribe@yahoogroups.com
            >
            >
            >
            > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            Service.
          Your message has been successfully submitted and would be delivered to recipients shortly.