Loading ...
Sorry, an error occurred while loading the content.
 

DIME test killing the White Mesa service...

Expand Messages
  • Rosimildo daSIlva
    I have reasons to believe that my client is bringing the WM service ( dime lit/doc ) down. Initially, I thought that the server was down.... but, this time
    Message 1 of 6 , Oct 9, 2002
      I have reasons to believe that my client is
      bringing the WM service ( dime lit/doc ) down.

      Initially, I thought that the server was down....
      but, this time I've tried to use the browser
      right after starting the test, and the
      browser also timed out. After, a minute or
      so, the service is up again......

      Bob, is anything I can do help debugging this.... ?
      the same client pass all MSSDK 3.0 tests....

      Rosimildo.





      __________________________________________________
      Do you Yahoo!?
      Faith Hill - Exclusive Performances, Videos & More
      http://faith.yahoo.com
    • Bob Cunnings
      Hi, I think you are right, I ve noticed unexpected termination of the service from time to time, in the recent past. Nothing turns up in the log, so I ve been
      Message 2 of 6 , Oct 10, 2002
        Hi,

        I think you are right, I've noticed unexpected termination of the service
        from time to time, in the recent past. Nothing turns up in the log, so I've
        been suspecting an unhandled exception, but could not correlate with any
        particular request, so your information is most helpful. It would be nice to
        have a copy of the actual request message so that I can try to duplicate the
        fault, if that is easy for you to do. At a minimum I'll set up to log the
        raw data from the socket and ask you to retry the request.

        Thanks,

        RC

        > I have reasons to believe that my client is
        > bringing the WM service ( dime lit/doc ) down.
        >
        > Initially, I thought that the server was down....
        > but, this time I've tried to use the browser
        > right after starting the test, and the
        > browser also timed out. After, a minute or
        > so, the service is up again......
        >
        > Bob, is anything I can do help debugging this.... ?
        > the same client pass all MSSDK 3.0 tests....
        >
        > Rosimildo.
      • Rosimildo daSIlva
        ... I can e-mail you my client executable. You would run it, and it will cause the failure. Is the e-mail: cunnings@whitemesa.com the right one to send to ?
        Message 3 of 6 , Oct 11, 2002
          --- Bob Cunnings <cunnings@...> wrote:
          > Hi,
          >
          > I think you are right, I've noticed unexpected
          > termination of the service
          > from time to time, in the recent past. Nothing turns
          > up in the log, so I've
          > been suspecting an unhandled exception, but could
          > not correlate with any
          > particular request, so your information is most
          > helpful. It would be nice to
          > have a copy of the actual request message so that I
          > can try to duplicate the
          > fault, if that is easy for you to do. At a minimum
          > I'll set up to log the
          > raw data from the socket and ask you to retry the
          > request.
          >
          > Thanks,
          >
          > RC

          I can e-mail you my client executable. You would run
          it,
          and it will cause the failure.

          Is the e-mail: cunnings@... the right one
          to send to ?

          Rosimildo.







          __________________________________________________
          Do you Yahoo!?
          Faith Hill - Exclusive Performances, Videos & More
          http://faith.yahoo.com
        • Bob Cunnings
          Yes, that s the right address. Thanks! RC
          Message 4 of 6 , Oct 11, 2002
            Yes, that's the right address.

            Thanks!

            RC
            >
            > I can e-mail you my client executable. You would run
            > it,
            > and it will cause the failure.
            >
            > Is the e-mail: cunnings@... the right one
            > to send to ?
            >
            > Rosimildo.
            >
          • Bob Cunnings
            Hi, The client exe works fine, all is now revealed. The request message looks like this:
            Message 5 of 6 , Oct 11, 2002
              Hi,

              The client exe works fine, all is now revealed. The request message looks
              like this:

              <?xml version="1.0"?><s:Envelope
              xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
              xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><m:EchoAttachmen
              ts xmlns:m="http://soapinterop.org/attachments/xsd"><m:In><m:Item
              href="uuid:A6F24290-FB78-4C6D-9820-D5EE44FF3054"></m:Item><m:Item
              href="uuid:46D3CAEF-513F-4441-A7F8-231410B92D99"></m:Item></m:In></m:EchoAtt
              achments></s:Body></s:Envelope>

              the problem is that the attachment is referenced using the "href" attribute,
              not the "location" attribute that is expected by the doc/literal version of
              the DIME service as described in the WSDL at
              http://www.pocketsoap.com/interop/dime-doc.wsdl.

              The WM test service did not handle this gracefully because of a silly bug in
              the echoAttachment operation implementation, which has been fixed. Now you
              can send a request like the above without ill effect, but the response will
              contain no attachment. Some example requests can be seen in the wire dumps
              at: http://www.whitemesa.com/interop/results/r4/dime-doc/results.htm.

              BTW, I noticed that the client was reporting a wsdl url for the service of
              http://www.whitemesa.net/interop/r4/dimedoc.wsdl which is a bad URL, it
              should be http://www.whitemesa.net/wsdl/r4/dime-doc-test.wsdl for the
              doc/lit DIME endpoint.

              Thanks again,

              RC

              >
              > I can e-mail you my client executable. You would run
              > it,
              > and it will cause the failure.
              >
              > Is the e-mail: cunnings@... the right one
              > to send to ?
              >
              > Rosimildo.
              >
              >
              >
              >
              >
              >
              >
              > __________________________________________________
              > Do you Yahoo!?
              > Faith Hill - Exclusive Performances, Videos & More
              > http://faith.yahoo.com
              >
              >
              > -----------------------------------------------------------------
              > This group is a forum for builders of SOAP implementations to discuss
              implementation and interoperability issues. Please stay on-topic.
              >
              > To unsubscribe from this group, send an email to:
              > soapbuilders-unsubscribe@yahoogroups.com
              >
              >
              >
              > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
              >
              >
              >
            • Rosimildo daSIlva
              ... xmlns:enc= http://schemas.xmlsoap.org/soap/encoding/ ... xmlns:s= http://schemas.xmlsoap.org/soap/envelope/
              Message 6 of 6 , Oct 12, 2002
                --- Bob Cunnings <cunnings@...> wrote:
                > Hi,
                >
                > The client exe works fine, all is now revealed. The
                > request message looks
                > like this:
                >
                > <?xml version="1.0"?><s:Envelope
                >
                xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
                >
                xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><m:EchoAttachmen
                > ts
                >
                xmlns:m="http://soapinterop.org/attachments/xsd"><m:In><m:Item
                >
                href="uuid:A6F24290-FB78-4C6D-9820-D5EE44FF3054"></m:Item><m:Item
                >
                href="uuid:46D3CAEF-513F-4441-A7F8-231410B92D99"></m:Item></m:In></m:EchoAtt
                > achments></s:Body></s:Envelope>
                >
                > the problem is that the attachment is referenced
                > using the "href" attribute,
                > not the "location" attribute that is expected by the
                > doc/literal version of
                > the DIME service as described in the WSDL at
                > http://www.pocketsoap.com/interop/dime-doc.wsdl.
                >
                > The WM test service did not handle this gracefully
                > because of a silly bug in
                > the echoAttachment operation implementation, which
                > has been fixed. Now you
                > can send a request like the above without ill
                > effect, but the response will
                > contain no attachment. Some example requests can be
                > seen in the wire dumps
                > at:
                >
                http://www.whitemesa.com/interop/results/r4/dime-doc/results.htm.
                >
                > BTW, I noticed that the client was reporting a wsdl
                > url for the service of
                > http://www.whitemesa.net/interop/r4/dimedoc.wsdl
                > which is a bad URL, it
                > should be
                > http://www.whitemesa.net/wsdl/r4/dime-doc-test.wsdl
                > for the
                > doc/lit DIME endpoint.
                >
                > Thanks again,
                >
                > RC

                Thanks for your time to test this, and pointing these
                problems to me. Yes, the stack on my side is
                under development for *attachments*, and I'll fix
                the problems you mentioned.

                Again, thanks for your testing.

                Rosimildo.








                __________________________________________________
                Do you Yahoo!?
                Faith Hill - Exclusive Performances, Videos & More
                http://faith.yahoo.com
              Your message has been successfully submitted and would be delivered to recipients shortly.