Loading ...
Sorry, an error occurred while loading the content.

XSD Interop Client results

Expand Messages
  • Arun Gupta
    ASP.NET WSDL has soap:address location as http://localhost/asmx/xsd/round4xsd.asmx . It should be http://mssoapinterop.org/asmx/xsd/round4XSD.asmx. Otherwise
    Message 1 of 5 , Oct 3, 2002
    • 0 Attachment
      ASP.NET WSDL has soap:address location as
      "http://localhost/asmx/xsd/round4xsd.asmx". It should be
      http://mssoapinterop.org/asmx/xsd/round4XSD.asmx. Otherwise all methods
      pass.

      WM service endpoint is giving problems with echoHexBinary. The request
      and response are given below:

      Request
      Content-Type: text/xml; charset="utf-8"
      Content-Length: 541
      SOAPAction: "http://soapinterop.org/echoHexBinary"
      <?xml version="1.0" encoding="UTF-8"?>
      <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
      env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><env:Body><ns0:echoHexBinary
      env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns0:echoHexBinary></env:Body></env:Envelope>

      Response
      Content-Type: text/xml; charset="utf-8"
      Content-Length: 541
      SOAPAction: "http://soapinterop.org/echoHexBinary"
      <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode
      xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><faultstring>Unexpected
      Error occurred while processing Body.</faultstring><detail><wm:time
      xmlns:wm="http://whitemesa.net/fault/">2002-10-03T19:42:03Z</wm:time></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

      Thanks,
      -Arun

      --
      =============================================
      There is only one me, I must live myself!
      There is only one today, I must live itself!
      =============================================
      http://members.tripod.com/~apgupta/index.html
      =============================================
    • Bob Cunnings
      Ok, echoHexBinary has been fixed. Thanks, RC ... env:encodingStyle= http://schemas.xmlsoap.org/soap/encoding/
      Message 2 of 5 , Oct 4, 2002
      • 0 Attachment
        Ok, echoHexBinary has been fixed.

        Thanks,

        RC

        > ASP.NET WSDL has soap:address location as
        > "http://localhost/asmx/xsd/round4xsd.asmx". It should be
        > http://mssoapinterop.org/asmx/xsd/round4XSD.asmx. Otherwise all methods
        > pass.
        >
        > WM service endpoint is giving problems with echoHexBinary. The request
        > and response are given below:
        >
        > Request
        > Content-Type: text/xml; charset="utf-8"
        > Content-Length: 541
        > SOAPAction: "http://soapinterop.org/echoHexBinary"
        > <?xml version="1.0" encoding="UTF-8"?>
        > <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
        > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
        > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
        >
        env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><env:Body><ns0
        :echoHexBinary
        >
        env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns
        0:echoHexBinary></env:Body></env:Envelope>
        >
        > Response
        > Content-Type: text/xml; charset="utf-8"
        > Content-Length: 541
        > SOAPAction: "http://soapinterop.org/echoHexBinary"
        > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
        >
        xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><S
        OAP-ENV:Fault><faultcode
        >
        xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><f
        aultstring>Unexpected
        > Error occurred while processing Body.</faultstring><detail><wm:time
        >
        xmlns:wm="http://whitemesa.net/fault/">2002-10-03T19:42:03Z</wm:time></detai
        l></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
        >
        > Thanks,
        > -Arun
        >
        > --
        > =============================================
        > There is only one me, I must live myself!
        > There is only one today, I must live itself!
        > =============================================
        > http://members.tripod.com/~apgupta/index.html
        > =============================================
        >
        >
      • Arun Gupta
        I m still getting the same error for echoHexBinary with WM. Here are the request and response messages: Request:
        Message 3 of 5 , Oct 5, 2002
        • 0 Attachment
          I'm still getting the same error for echoHexBinary with WM. Here are the
          request and response messages:

          Request:

          <soap-env:Envelope
          xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/"
          xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
          xmlns:xsd="http://www.w3.org/2001/XMLSchema"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
          xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
          env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><soap-env:Body><ns0:echoHexBinary
          env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns0:echoHexBinary></soap-env:Body></soap-env:Envelope>

          Response:

          <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
          xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode
          xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><faultstring>Unexpected
          Error occurred while processing Body.</faultstring><detail><wm:time
          xmlns:wm="http://whitemesa.net/fault/">2002-10-05T15:52:59Z</wm:time></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

          Thanks,
          -Arun

          Bob Cunnings wrote:

          > Ok, echoHexBinary has been fixed.
          >
          > Thanks,
          >
          > RC
          >
          > > ASP.NET WSDL has soap:address location as
          > > "http://localhost/asmx/xsd/round4xsd.asmx". It should be
          > > http://mssoapinterop.org/asmx/xsd/round4XSD.asmx. Otherwise all methods
          > > pass.
          > >
          > > WM service endpoint is giving problems with echoHexBinary. The request
          > > and response are given below:
          > >
          > > Request
          > > Content-Type: text/xml; charset="utf-8"
          > > Content-Length: 541
          > > SOAPAction: "http://soapinterop.org/echoHexBinary"
          > > <?xml version="1.0" encoding="UTF-8"?>
          > > <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
          > > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
          > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          > > xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
          > > xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
          > >
          > env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><env:Body><ns0
          > :echoHexBinary
          > >
          > env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns
          > 0:echoHexBinary></env:Body></env:Envelope>
          > >
          > > Response
          > > Content-Type: text/xml; charset="utf-8"
          > > Content-Length: 541
          > > SOAPAction: "http://soapinterop.org/echoHexBinary"
          > > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
          > >
          > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><S
          > OAP-ENV:Fault><faultcode
          > >
          > xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><f
          > aultstring>Unexpected
          > > Error occurred while processing Body.</faultstring><detail><wm:time
          > >
          > xmlns:wm="http://whitemesa.net/fault/">2002-10-03T19:42:03Z</wm:time></detai
          > l></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
          > >
          > > Thanks,
          > > -Arun
          > >
          > > --
          > > =============================================
          > > There is only one me, I must live myself!
          > > There is only one today, I must live itself!
          > > =============================================
          > > http://members.tripod.com/~apgupta/index.html
          > > =============================================
          > >
          > >
          >
          >
          >
          >
          >
          > Yahoo! Groups Sponsor
          > ADVERTISEMENT
          > <http://rd.yahoo.com/M=213858.2436161.3858594.2225242/D=egroupweb/S=1705701014:HM/A=763352/R=0/*http://www.classmates.com/index.tf?s=5085>
          >
          >
          > -----------------------------------------------------------------
          > This group is a forum for builders of SOAP implementations to discuss
          > implementation and interoperability issues. Please stay on-topic.
          >
          > To unsubscribe from this group, send an email to:
          > soapbuilders-unsubscribe@yahoogroups.com
          >
          >
          >
          > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
          > <http://docs.yahoo.com/info/terms/>.


          --
          =============================================
          There is only one me, I must live myself!
          There is only one today, I must live itself!
          =============================================
          http://members.tripod.com/~apgupta/index.html
          =============================================
        • Bob Cunnings
          Well, I managed to foul that up, but it s straightened out now, at least tests ok from here. RC ...
          Message 4 of 5 , Oct 5, 2002
          • 0 Attachment
            Well, I managed to foul that up, but it's straightened out now, at least
            tests ok from here.

            RC

            > I'm still getting the same error for echoHexBinary with WM. Here are the
            > request and response messages:
            >
            > Request:
            >
            > <soap-env:Envelope
            > xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/"
            > xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
            > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            > xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
            > xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
            >
            env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><soap-env:Body
            ><ns0:echoHexBinary
            >
            env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns
            0:echoHexBinary></soap-env:Body></soap-env:Envelope>
            >
            > Response:
            >
            > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
            >
            xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><S
            OAP-ENV:Fault><faultcode
            >
            xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><f
            aultstring>Unexpected
            > Error occurred while processing Body.</faultstring><detail><wm:time
            >
            xmlns:wm="http://whitemesa.net/fault/">2002-10-05T15:52:59Z</wm:time></detai
            l></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
            >
            > Thanks,
            > -Arun
            >
          • Arun Gupta
            echoHexBinary works passes now. I ll look at echoVoidSoapHeader next. Thanks, -Arun ... -- ============================================= There is only one me,
            Message 5 of 5 , Oct 5, 2002
            • 0 Attachment
              echoHexBinary works passes now. I'll look at echoVoidSoapHeader next.

              Thanks,
              -Arun

              Bob Cunnings wrote:

              > Well, I managed to foul that up, but it's straightened out now, at least
              > tests ok from here.
              >
              > RC
              >
              > > I'm still getting the same error for echoHexBinary with WM. Here are the
              > > request and response messages:
              > >
              > > Request:
              > >
              > > <soap-env:Envelope
              > > xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/"
              > > xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
              > > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
              > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              > > xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
              > > xmlns:ns0="http://soapinterop.org/" xmlns:ns1="http://soapinterop.org"
              > >
              > env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><soap-env:Body
              > ><ns0:echoHexBinary
              > >
              > env:encodingStyle=""><ns0:inputHexBinary>80ff00017f</ns0:inputHexBinary></ns
              > 0:echoHexBinary></soap-env:Body></soap-env:Envelope>
              > >
              > > Response:
              > >
              > > <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
              > >
              > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><S
              > OAP-ENV:Fault><faultcode
              > >
              > xmlns:ns="http://schemas.xmlsoap.org/soap/envelope/">ns:Client</faultcode><f
              > aultstring>Unexpected
              > > Error occurred while processing Body.</faultstring><detail><wm:time
              > >
              > xmlns:wm="http://whitemesa.net/fault/">2002-10-05T15:52:59Z</wm:time></detai
              > l></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
              > >
              > > Thanks,
              > > -Arun
              > >
              >
              >
              >
              >
              >
              > Yahoo! Groups Sponsor
              > ADVERTISEMENT
              > <http://rd.yahoo.com/M=213858.2436161.3858594.2225242/D=egroupweb/S=1705701014:HM/A=763352/R=0/*http://www.classmates.com/index.tf?s=5085>
              >
              >
              > -----------------------------------------------------------------
              > This group is a forum for builders of SOAP implementations to discuss
              > implementation and interoperability issues. Please stay on-topic.
              >
              > To unsubscribe from this group, send an email to:
              > soapbuilders-unsubscribe@yahoogroups.com
              >
              >
              >
              > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
              > <http://docs.yahoo.com/info/terms/>.


              --
              =============================================
              There is only one me, I must live myself!
              There is only one today, I must live itself!
              =============================================
              http://members.tripod.com/~apgupta/index.html
              =============================================
            Your message has been successfully submitted and would be delivered to recipients shortly.