Loading ...
Sorry, an error occurred while loading the content.
 

Re: [soapbuilders] IDOX WASP R1 interop problem (1999/2001)

Expand Messages
  • Mirek Simek
    Hello Kent, Yes, this is a known bug in the version of WASP 1.0 (the one referenced from www.xmethods.net/ilab). Because Idoox is preparing a new generation of
    Message 1 of 5 , Aug 30, 2001
      Hello Kent,
      Yes, this is a known bug in the version of WASP 1.0 (the one
      referenced from www.xmethods.net/ilab).
      Because Idoox is preparing a new generation of soap runtime
      (code-named stardust, beta 1 is currently available for download at
      www.idoox.com), we have decided not to fix this wrong behavior
      in WASP 1.0.
      Link to stardust, which handles correctly both problems stated in this
      thread, will be added in one month.

      Sorry for inconvenience

                          Mirek Simek
      -- 
      
      Mirek Simek
      www.idoox.com
      


      Alan Kent wrote:
      On Thu, Aug 30, 2001 at 12:09:45AM -0500, Matt Long wrote:
      > I think it doesn't like xsi:type="SOAP-ENC:Array"

          <m:echoStringArray xmlns:m="http://soapinterop.org/ ">
            <inputStringArray
                  xsi:type="SOAP-ENC:Array"
                  SOAP-ENC:arrayType="xsd:string[2]">
                <item xsi:type="xsd:string">HELLO</item>
                <item xsi:type="xsd:string">GOODBYE</item>
            </inputStringArray>
          </m:echoStringArray>

      Are you saying that IDOX has a bug or that my packet is malformed?
      My reading of the spec (which may be wrong) says I am doing the
      correct thing. Also looking at the HP packets (for example) does
      the same thing.

      Could you clarify who is wrong and what the correct behaviour is?

      Thanks
      Alan


      -----------------------------------------------------------------
      This group is a forum for builders of SOAP implementations to discuss implementation and interoperability issues.  Please stay on-topic.

      To unsubscribe from this group, send an email to:
      soapbuilders-unsubscribe@yahoogroups.com



      Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service .


    Your message has been successfully submitted and would be delivered to recipients shortly.