Loading ...
Sorry, an error occurred while loading the content.

Re: [soapbuilders] Apache SOAP and Scott Seely's SimpleSoap library

Expand Messages
  • Rosimildo da Silva
    First, do not post as HTML. It is very painful for some people, and others might not be able to handle your post at all.The error message from Apache is very
    Message 1 of 2 , Jun 1, 2001
    • 0 Attachment
      First, do not post as HTML. It is very painful for some people, and others
      might not
      be able to handle your post at all.

      The error message from Apache is very clear. You are not sending a proper
      namespaced
      method request to the server. See "ns1" prefix on the apache message. It is
      the namespace
      for the method element.

      I do not know the Scott Seely's SimpleSoap library, but your should be able
      to
      specify the local URI as xmlns:ns1="urn:test:soapserver"

      Rosimildo.

      ----- Original Message -----
      From: ss2shin@...
      To: soapbuilders@yahoogroups.com
      Sent: Thursday, May 31, 2001 5:09 PM
      Subject: [soapbuilders] Apache SOAP and Scott Seely's SimpleSoap library


      Hello

      I am currently experimenting with SOAP, and built a simple server
      using Apche SOAP.

      I also found a simple SOAP library in C++ in Scott Seely book and
      tried to use it to build a simple client using Visual C++. (I already
      succeeded building a client using Java.)

      However, I am getting this error.

      <faultcode>SOAP-ENV:Server.BadTargetObjectURI</faultcode>
      <faultstring>Unable to determine object id from call: is the method
      element namespaced?</faultstring>
      <faultactor>/soap/servlet/rpcrouter</faultactor>

      I found out that there is this tag missing in the message which was
      in the message generated by the client written in Java.

      Java :

      <ns1:synchronize xmlns:ns1="urn:test:soapserver" SOAP-
      ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

      Scott Seely's library :

      <synchronize SOAP-
      ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" >

      The rest is exactly the same.

      Can anyone help me what to do to make this work?

      Thanks.


      Yahoo! Groups Sponsor



      To unsubscribe from this group, send an email to:
      soapbuilders-unsubscribe@yahoogroups.com



      Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


      _________________________________________________________
      Do You Yahoo!?
      Get your free @... address at http://mail.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.