Loading ...
Sorry, an error occurred while loading the content.

Re: IV-17 SS kinda working!

Expand Messages
  • fixitsan2
    Such is the way of progress I suppose. We ve all been there, I m sure of that ! I m wondering if changing the values of the resitors will help you to increase
    Message 1 of 9 , May 27, 2011
    • 0 Attachment
      Such is the way of progress I suppose. We've all been there, I'm sure of that !

      I'm wondering if changing the values of the resitors will help you to increase the brightness of the DP's. Perhaps raising the value of the 10k resitors and/or reducing the value of the 100k resistors. I didn't calculate the resitor values to check the biasing of the transistors is correct, merely scaled down a circuit for a higher voltage. If I get around to it I'll have another look at that.
      I would like to get them working well because they are a very cheap optionfor driving the segments too, 22 pairs of transistors with accompanying resistors plus a pic would be all that would be required if using the generic circuit version of the software.

      Chris


      --- In smartsockets@yahoogroups.com, "shklaw75" <shklaw75@...> wrote:
      >
      >
      >
      >
      >
      > Hi Chris,
      >
      > I understood which part of the schematic you were referring to, thanks for the clarification.
      >
      > The decimal points are working, although slightly duller compared to the other segments. The values of the resistors I am using are 33k for the bases of the MPS42's, 100k from the collector of the MPS42 to the base of the MPS92. 10k's between the base of the MPS92 and the 40V supply and 1k between the collector of the MPS92 and the left or right group of decimal points. I also tried without the 1k and the brightness seems the same.
      >
      > Now, I have gone and done something stupid and think I have damaged the PIC chip and maybe the HV5812! I was sticking 12V into pin 14 of the PIC (to illuminate all the segments) by accident and now i cant get anything to come up except for the decimal points! So i will get another PIC in and get it working again. I will then update you on where it is all at.
      >
      > Cheers.
      > Simon
      >
      >
      >
      > --- In smartsockets@yahoogroups.com, "fixitsan2" <fixitsan@> wrote:
      > >
      > > Simon, apologies, I changed the link and forgot to change the reference to it (working in too much of a rush...)
      > >
      > > The area of the diagram concerned is top right.
      > >
      > > --- In smartsockets@yahoogroups.com, "fixitsan2" <fixitsan@> wrote:
      > > referencing the schematic on the last page of this manual....
      > > > http://www.ledsales.com.au/pdf/frank2_clock_kit.pdf
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.