Loading ...
Sorry, an error occurred while loading the content.

Version 13 released, PWM control and display test features added

Expand Messages
  • fixitsan2
    In the IV-17 files section is V13 software. (V12 will stay there for a little while longer, just in case) Pin 2 - 0..5Vdc input adjusts PWM output duty cycle
    Message 1 of 4 , Apr 25, 2011
    • 0 Attachment
      In the IV-17 files section is V13 software. (V12 will stay there for a little while longer, just in case)

      Pin 2 - 0..5Vdc input adjusts PWM output duty cycle from pin 13 0-100%
      Pin 3 - 0..5Vdc input adjusts PWM frequency at pin 13 12kHz-55kHz approx
      pin 14 - Keep low for normal operation, set high to turn on all segments


      Chris
    • guus.assmann@wolmail.nl
      Hello Chris, Finally I came round to testing again. I have a PICKIT 2 prigrammer now. This one reports that some of the settings are not in the file. The
      Message 2 of 4 , Oct 8, 2011
      • 0 Attachment
        Hello Chris,

        Finally I came round to testing again.
        I have a PICKIT 2 prigrammer now.
        This one reports that some of the settings are not in the file.
        The defaults are used and I guess these are wrong.
        Current config:
        Config1 = $C800
        Config2 = $1F1F
        Config3 = $8D00
        Config4 = $0081
        Config5 = $C00F
        Config6 = $E00F
        Config7 = $400F
        Can you please tell me what they should be?
        I cannot find it in the source code. Maybe I'm not looking at the right place.

        BR/
        Guus

        >-- Oorspronkelijk bericht --
        >To: smartsockets@yahoogroups.com
        >From: "fixitsan2" <fixitsan@...>
        >Date: Mon, 25 Apr 2011 14:19:53 -0000
        >Subject: [smartsockets] Version 13 released, PWM control and display test
        >features added
        >Reply-To: smartsockets@yahoogroups.com
        >
        >
        >In the IV-17 files section is V13 software. (V12 will stay there for a little
        >while longer, just in case)
        >
        >Pin 2 - 0..5Vdc input adjusts PWM output duty cycle from pin 13 0-100%
        >Pin 3 - 0..5Vdc input adjusts PWM frequency at pin 13 12kHz-55kHz approx
        >pin 14 - Keep low for normal operation, set high to turn on all segments
        >
        >
        >Chris
        >
      • fixitsan2
        Hi Guus, I also get the same message warning that some configs are not included, but the defalts have always worked for me. I am using the pickit 2 also. I
        Message 3 of 4 , Nov 3, 2011
        • 0 Attachment
          Hi Guus,
          I also get the same message warning that some configs are not included, but the defalts have always worked for me.
          I am using the pickit 2 also.

          I used to program at home and at work too. At home I use a desktop machine, making changes and then uploading to the iles section.
          When i was quite in the field at work i would download using my laptop and program a pic using the same hex file but a different pickit 2. It didn's seem to matter whcih device I used, both would read the hex and the default pickit config settings always work.

          The config bits are set with Picbasic and MPASM. If the bits are not assigned in Picbasic a few defaults are used instead, such as WDT,MCLR, the usual pic stuff. but I overwrite the defaults with preffered settings (WDT OFF as opposed to the default of ON)

          After the first time you told me about this problem I downloaded the file from the files section and tried programming a pic with it, which worked for me.

          It is difficult for me to get a better sense of why the programming is failing, all I know is that the defaults of the latest pickit software, which I know you must have downloaded and installed otherwise it would not recognise the device correctly, seem to be working here.

          Chris





          --- In smartsockets@yahoogroups.com, "guus.assmann@..." <guus.assmann@...> wrote:
          >
          > Hello Chris,
          >
          > Finally I came round to testing again.
          > I have a PICKIT 2 prigrammer now.
          > This one reports that some of the settings are not in the file.
          > The defaults are used and I guess these are wrong.
          > Current config:
          > Config1 = $C800
          > Config2 = $1F1F
          > Config3 = $8D00
          > Config4 = $0081
          > Config5 = $C00F
          > Config6 = $E00F
          > Config7 = $400F
          > Can you please tell me what they should be?
          > I cannot find it in the source code. Maybe I'm not looking at the right place.
          >
          > BR/
          > Guus
          >
          > >-- Oorspronkelijk bericht --
          > >To: smartsockets@yahoogroups.com
          > >From: "fixitsan2" <fixitsan@...>
          > >Date: Mon, 25 Apr 2011 14:19:53 -0000
          > >Subject: [smartsockets] Version 13 released, PWM control and display test
          > >features added
          > >Reply-To: smartsockets@yahoogroups.com
          > >
          > >
          > >In the IV-17 files section is V13 software. (V12 will stay there for a little
          > >while longer, just in case)
          > >
          > >Pin 2 - 0..5Vdc input adjusts PWM output duty cycle from pin 13 0-100%
          > >Pin 3 - 0..5Vdc input adjusts PWM frequency at pin 13 12kHz-55kHz approx
          > >pin 14 - Keep low for normal operation, set high to turn on all segments
          > >
          > >
          > >Chris
          > >
          >
        • guus.assmann@wolmail.nl
          Hello Chris, Then, it seems it cannot be solved in a simple way, by just using E-mail. The only thing I can think of now, is to send my processors to you. Then
          Message 4 of 4 , Nov 3, 2011
          • 0 Attachment
            Hello Chris,

            Then, it seems it cannot be solved in a simple way, by just using E-mail.
            The only thing I can think of now, is to send my processors to you.
            Then you can program and test and send back to be.
            After that, I can read the device and try to copy it.
            Can we do like that? (And how can I pay the postage back to me? Paypal?)

            Another alternative would be if you sell me a programmed PIC.
            I have used a DIL version, 18F26K20.
            Then I can try to copy that one. (Maybe less work :-)

            BR/
            Guus

            >-- Oorspronkelijk bericht --
            >To: smartsockets@yahoogroups.com
            >From: "fixitsan2" <fixitsan@...>
            >Date: Thu, 03 Nov 2011 09:05:18 -0000
            >Subject: [smartsockets] Re: Version 13 released, PWM control and display
            >test features added
            >Reply-To: smartsockets@yahoogroups.com
            >
            >
            >Hi Guus,
            >I also get the same message warning that some configs are not included,
            but
            >the defalts have always worked for me.
            >I am using the pickit 2 also.
            >
            >I used to program at home and at work too. At home I use a desktop machine,
            >making changes and then uploading to the iles section.
            >When i was quite in the field at work i would download using my laptop and
            >program a pic using the same hex file but a different pickit 2. It didn's
            >seem to matter whcih device I used, both would read the hex and the default
            >pickit config settings always work.
            >
            >The config bits are set with Picbasic and MPASM. If the bits are not assigned
            >in Picbasic a few defaults are used instead, such as WDT,MCLR, the usual
            >pic stuff. but I overwrite the defaults with preffered settings (WDT OFF
            >as opposed to the default of ON)
            >
            >After the first time you told me about this problem I downloaded the file
            >from the files section and tried programming a pic with it, which worked
            >for me.
            >
            >It is difficult for me to get a better sense of why the programming is failing,
            >all I know is that the defaults of the latest pickit software, which I know
            >you must have downloaded and installed otherwise it would not recognise
            the
            >device correctly, seem to be working here.
            >
            >Chris
            >
            >
            >
            >
            >
            >--- In smartsockets@yahoogroups.com, "guus.assmann@..." <guus.assmann@...>
            >wrote:
            >>
            >> Hello Chris,
            >>
            >> Finally I came round to testing again.
            >> I have a PICKIT 2 prigrammer now.
            >> This one reports that some of the settings are not in the file.
            >> The defaults are used and I guess these are wrong.
            >> Current config:
            >> Config1 = $C800
            >> Config2 = $1F1F
            >> Config3 = $8D00
            >> Config4 = $0081
            >> Config5 = $C00F
            >> Config6 = $E00F
            >> Config7 = $400F
            >> Can you please tell me what they should be?
            >> I cannot find it in the source code. Maybe I'm not looking at the right
            >place.
            >>
            >> BR/
            >> Guus
            >>
            >> >-- Oorspronkelijk bericht --
            >> >To: smartsockets@yahoogroups.com
            >> >From: "fixitsan2" <fixitsan@...>
            >> >Date: Mon, 25 Apr 2011 14:19:53 -0000
            >> >Subject: [smartsockets] Version 13 released, PWM control and display
            test
            >> >features added
            >> >Reply-To: smartsockets@yahoogroups.com
            >> >
            >> >
            >> >In the IV-17 files section is V13 software. (V12 will stay there for
            a
            >little
            >> >while longer, just in case)
            >> >
            >> >Pin 2 - 0..5Vdc input adjusts PWM output duty cycle from pin 13 0-100%
            >> >Pin 3 - 0..5Vdc input adjusts PWM frequency at pin 13 12kHz-55kHz approx
            >> >pin 14 - Keep low for normal operation, set high to turn on all segments
            >> >
            >> >
            >> >Chris
            >> >
            >>
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.