Loading ...
Sorry, an error occurred while loading the content.

Betr: [smartsockets] Re: 2 tube clock with PIC16F88

Expand Messages
  • guus.assmann@wolmail.nl
    Hello Chris, No problem. It s a hobby. The 16F88 stil doesn t work. I ve tested a number of combinations, no success. Once I press the button, the word clock
    Message 1 of 52 , Apr 17, 2008
    • 0 Attachment
      Hello Chris,

      No problem. It's a hobby.

      The 16F88 stil doesn't work.
      I've tested a number of combinations, no success.
      Once I press the button, the word "clock" comes back.
      It looks like a reset.
      Maybe the schematics are wrong in some way?
      I've wired the stuff on a PCB with holes only. Very little chance of mistakes
      there.
      The button I use, closes the contact when pressed. Maybe this differs from
      the rotary-encoder button?

      And unfortunatelly'I also got another problem.
      The ZM1350 PCB that I made, works fine now.
      But the 7179 one I made, has the segments wrong.
      When a C should be displayed, segments 9, 10, 11 and 2 work.
      This goes for the other segmants as well.
      So the schematics in the attachment don't match the table in version 2 of
      the software. (SMARTV2)
      The schematics were taken from the website and redrawn in my design package.
      I did this because then I can make PDF's. And these make good prints on our
      (company) laserprinter. Thus I can make a printout in normal and mirrored
      that I can glue together. This makes a nice dark mask.

      BR/
      Guus

      >-- Oorspronkelijk bericht --
      >To: smartsockets@yahoogroups.com
      >From: "Chris" <fixitsan@...>
      >Date: Wed, 16 Apr 2008 19:49:31 -0000
      >Subject: [smartsockets] Re: 2 tube clock with PIC16F88
      >Reply-To: smartsockets@yahoogroups.com
      >
      >
      >--- In smartsockets@yahoogroups.com, guus.assmann@... wrote:
      >>
      >> Hello Chris,
      >>
      >> Still, I didn't get the clock to work.
      >> Can you please check the configuration words?
      >> The current ones in my processor: word 1 = 3FA9 and word 2 = 003
      >>
      >> BR/
      >> Guus
      >>
      >
      >Sorry for the delay, had to go away for a few days of work
      >
      >Guus, my programmer has two 'fuse words' which I suppose must be the
      >configs.
      >
      >For an HS oscillator....
      >Word1 = 3F02 Word2 = 3FFD
      >
      >
      >For using the internal oscillator (for testing perhaps)
      >Word1 = 3F10 Word2 = 3FFD
      >
      >
      >Please let me know if this helps any. The 16F88 has oscillator
      >changeover options, as well as failsafe config bit. I could play
      >around with those and recompile for you if required (which might
      >help us both in the long run)
      >
      >
    • Chris
      ... the programm ... fine. ... Guus, Thanks for the update. I haven t been getting the time to do what I need to do either ! Chris
      Message 52 of 52 , Aug 23, 2008
      • 0 Attachment
        --- In smartsockets@yahoogroups.com, guus.assmann@... wrote:
        >
        > Hello Chris,
        >
        > Just now I realise that I forgot to inform you.
        > During my holliday, I had some more time and finally managed to get
        the programm
        > correct. So now, the smartsocket with the B7179 on my PCB also works
        fine.
        > I'll make some more, to get all 7 tubes working.
        >
        > BR/
        > Guus
        >

        Guus, Thanks for the update.

        I haven't been getting the time to do what I need to do either !

        Chris
      Your message has been successfully submitted and would be delivered to recipients shortly.