Loading ...
Sorry, an error occurred while loading the content.

installskydb

Expand Messages
  • gjerte
    Ok, I have it installed now - system user skylendar, postgres user, database (also skylendar) with unicode (UTF-8) and plpgsql language. Have two questions,
    Message 1 of 9 , Nov 28, 2007
    • 0 Attachment
      Ok, I have it installed now - system user skylendar, postgres user,
      database (also skylendar) with unicode (UTF-8) and plpgsql language.
      Have two questions, though, and I think they are Skylendar-specific
      enough to ask. If you think I should RTFM it would be very nice with
      a hint on what manual.

      From where do I run skygrant?
      I have tried to run it as root, superuser and whatever I could think
      of, but I get the same message "/usr/bin/skygrant must be executed
      as root !"

      I cant run installskydb either. I have modified the script as
      suggested in the forum, but it still gives "pg_hba.conf not found !"
      It would be really nice if you could have a look, heres the
      modificated part with the correct path:


      elif [ -w /etc/postgresql/8.1/main/pg_hba.conf ]; then
      export PGDATA=/etc/postgresql/8.1/main

      Thanks :)
    • stnsls
      ... Hello, What kind of Linux distro are you running? The scripts are tailored to Mandriva... and even on that distro, they are not extensively tested. There
      Message 2 of 9 , Nov 29, 2007
      • 0 Attachment
        --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@...> wrote:
        >
        > Ok, I have it installed now - system user skylendar, postgres user,
        > database (also skylendar) with unicode (UTF-8) and plpgsql language.
        > Have two questions, though, and I think they are Skylendar-specific
        > enough to ask. If you think I should RTFM it would be very nice with
        > a hint on what manual.
        >
        > From where do I run skygrant?
        > I have tried to run it as root, superuser and whatever I could think
        > of, but I get the same message "/usr/bin/skygrant must be executed
        > as root !"
        >
        > I cant run installskydb either. I have modified the script as
        > suggested in the forum, but it still gives "pg_hba.conf not found !"
        > It would be really nice if you could have a look, heres the
        > modificated part with the correct path:
        >
        >
        > elif [ -w /etc/postgresql/8.1/main/pg_hba.conf ]; then
        > export PGDATA=/etc/postgresql/8.1/main
        >
        > Thanks :)
        >

        Hello,

        What kind of Linux distro are you running? The scripts are tailored to
        Mandriva... and even on that distro, they are not extensively tested.
        There are multiple problems concerning portability...

        0) Install and run postgreql server with plpgsql plugin, install
        required libs (libqt3-devel, libqt3-psql, etc)
        1) Download source, untar, compile, install...
        2) Install the font found in src dir, possibly using kde font manager
        3) Copy skif.pm in your Perl modules dir (/usr/lib/perl5/something)
        4) Add a 'skylendar' system user
        5) Using the system postgresql user ('su postgres'), create a
        'skylendar' posgtres user with 'createuser skylendar', for example.
        6) then create a database UTF-8 encoded belonging to that user with
        'createdb skylendar -O skylendar -E utf8'
        7) then 'createlang plpgsql skylendar'
        8) then insert the default records inside the database with 'psql -f
        /path/to/src/installskydb.sql -U skylendar -d skylendar'

        I have forgotten how to install the icons...

        It seems to work for me like that. Good luck.
      • gjerte
        ... Hi :) Distro: I tried to install Mandriva 2007, but could not make it work, so I went back to Debian. I can see the weakness in that. Now, Mandriva have
        Message 3 of 9 , Nov 30, 2007
        • 0 Attachment
          --- In skylendar@yahoogroups.com, "stnsls" <stnsls@...> wrote:
          >
          > --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@> wrote:
          > >
          > > Ok, I have it installed now - system user skylendar, postgres user,
          > > database (also skylendar) with unicode (UTF-8) and plpgsql language.
          > > Have two questions, though, and I think they are Skylendar-specific
          > > enough to ask. If you think I should RTFM it would be very nice with
          > > a hint on what manual.
          > >
          > > From where do I run skygrant?
          > > I have tried to run it as root, superuser and whatever I could think
          > > of, but I get the same message "/usr/bin/skygrant must be executed
          > > as root !"
          > >
          > > I cant run installskydb either. I have modified the script as
          > > suggested in the forum, but it still gives "pg_hba.conf not found !"
          > > It would be really nice if you could have a look, heres the
          > > modificated part with the correct path:
          > >
          > >
          > > elif [ -w /etc/postgresql/8.1/main/pg_hba.conf ]; then
          > > export PGDATA=/etc/postgresql/8.1/main
          > >
          > > Thanks :)
          > >
          >
          > Hello,
          >
          > What kind of Linux distro are you running? The scripts are tailored to
          > Mandriva... and even on that distro, they are not extensively tested.
          > There are multiple problems concerning portability...
          >
          > 0) Install and run postgreql server with plpgsql plugin, install
          > required libs (libqt3-devel, libqt3-psql, etc)
          > 1) Download source, untar, compile, install...
          > 2) Install the font found in src dir, possibly using kde font manager
          > 3) Copy skif.pm in your Perl modules dir (/usr/lib/perl5/something)
          > 4) Add a 'skylendar' system user
          > 5) Using the system postgresql user ('su postgres'), create a
          > 'skylendar' posgtres user with 'createuser skylendar', for example.
          > 6) then create a database UTF-8 encoded belonging to that user with
          > 'createdb skylendar -O skylendar -E utf8'
          > 7) then 'createlang plpgsql skylendar'
          > 8) then insert the default records inside the database with 'psql -f
          > /path/to/src/installskydb.sql -U skylendar -d skylendar'
          >
          > I have forgotten how to install the icons...
          >
          > It seems to work for me like that. Good luck.
          >
          Hi :)

          Distro: I tried to install Mandriva 2007, but could not make it work,
          so I went back to Debian. I can see the weakness in that.
          Now, Mandriva have gone 2008. I could try to make an install of it and
          see if that works. I'm installing on an old Armada laptop, so
          maybe/maybe not...

          0)&7) I installed postgresql server, client and devel stuf. I have it
          running at startup. (+ installed QT, QTdevel and QT-postgresql plugin)
          The plpsql plugin is installed by default. According to the postgresql
          documentation you enable it by running "createlang plpsql Template1" -
          all later created databases will then have plpsql prosedural language
          by default (it was reported as having been done successfully.)

          1) After some initial problems with the QT path (thread on linuxforums
          here:
          http://www.linuxforums.org/forum/debian-linux-help/108948-setting-path-qt.html)
          I got the Skylendar install working.

          2) Font is installed (Using kde font manager.)

          3) Using Synaptic package manager I installed libxlm-dom-perl. I do
          not have skif.pm anywhere under /usr/lib/perl5/. I do, however have
          /usr/share/perl5/skif.pm and /usr/src/skylendar-1.7.0/src/skif.pm
          Guess this is a Debian thing? Should I copy it to somewhere under
          /usr/lib/perl5/?

          4)&5) Er ... cough... This is maybe where I should return to the linux
          newbee forum for a discussion about the differences between a postgres
          user and a system user... (?)
          After "su postgres" I did a "createuser skylendar" with the superuser
          flag. This user is reported as a system user in the Users and Groups
          utility. It also has it's own home folder /home/skylendar. This is not
          good enough?

          6) I have created the database. Used -E UNICODE, but it gave the same
          result. When I "su skylendar", "psql -U skylendar" and "skylendar=>
          \l", one of the databases listed are Name:skylendar, Owner:skylendar,
          Coding:UTF8

          8) :) ... "psql -f /usr/src/skylendar-1.7.0/src/installskydb.sql -U
          skylendar -d skylendar" worked - a bit...
          It generated a long output, but then it ended with:
          psql:/usr/src/skylendar-1.7.0/src/installskydb.sql:510: \connect
          FATAL: Ident authentication failed for user "postgres"
          I tried to "su postgres" and run the same command, but it just said:
          psql: FATAL: Ident authentication failed for user "skylendar"

          Icons? Overrated! :)

          But you don't mention skygrant. You don't need to run it?

          And, thanks! I do very much appreciate it :)
        • stnsls
          ... No I don t. ... Apparently, your psql users need a password. There is a very usefull command under linux: man . So: man man , man createuser , man
          Message 4 of 9 , Nov 30, 2007
          • 0 Attachment
            --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@...> wrote:

            > 4)&5) Er ... cough... This is maybe where I should return to the linux
            > newbee forum for a discussion about the differences between a postgres
            > user and a system user... (?)
            > After "su postgres" I did a "createuser skylendar" with the superuser
            > flag. This user is reported as a system user in the Users and Groups
            > utility. It also has it's own home folder /home/skylendar. This is not
            > good enough?
            >
            > 6) I have created the database. Used -E UNICODE, but it gave the same
            > result. When I "su skylendar", "psql -U skylendar" and "skylendar=>
            > \l", one of the databases listed are Name:skylendar, Owner:skylendar,
            > Coding:UTF8
            >
            > 8) :) ... "psql -f /usr/src/skylendar-1.7.0/src/installskydb.sql -U
            > skylendar -d skylendar" worked - a bit...
            > It generated a long output, but then it ended with:
            > psql:/usr/src/skylendar-1.7.0/src/installskydb.sql:510: \connect
            > FATAL: Ident authentication failed for user "postgres"
            > I tried to "su postgres" and run the same command, but it just said:
            > psql: FATAL: Ident authentication failed for user "skylendar"
            >
            > Icons? Overrated! :)
            >
            > But you don't mention skygrant. You don't need to run it?

            No I don't.

            > And, thanks! I do very much appreciate it :)
            >

            Apparently, your psql users need a password.
            There is a very usefull command under linux: "man".
            So: "man man", "man createuser", "man createdb", "man createlang"...
            www.postgresql.org has comprehensive documentation about relational
            database.
          • gjerte
            ... Thanks, I will read the relational database part in the documentation. I m working with a blindfold here, so it helps me a lot when I know what to look
            Message 5 of 9 , Nov 30, 2007
            • 0 Attachment
              --- In skylendar@yahoogroups.com, "stnsls" <stnsls@...> wrote:
              >
              > --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@> wrote:
              >
              > > 4)&5) Er ... cough... This is maybe where I should return to the linux
              > > newbee forum for a discussion about the differences between a postgres
              > > user and a system user... (?)
              > > After "su postgres" I did a "createuser skylendar" with the superuser
              > > flag. This user is reported as a system user in the Users and Groups
              > > utility. It also has it's own home folder /home/skylendar. This is not
              > > good enough?
              > >
              > > 6) I have created the database. Used -E UNICODE, but it gave the same
              > > result. When I "su skylendar", "psql -U skylendar" and "skylendar=>
              > > \l", one of the databases listed are Name:skylendar, Owner:skylendar,
              > > Coding:UTF8
              > >
              > > 8) :) ... "psql -f /usr/src/skylendar-1.7.0/src/installskydb.sql -U
              > > skylendar -d skylendar" worked - a bit...
              > > It generated a long output, but then it ended with:
              > > psql:/usr/src/skylendar-1.7.0/src/installskydb.sql:510: \connect
              > > FATAL: Ident authentication failed for user "postgres"
              > > I tried to "su postgres" and run the same command, but it just said:
              > > psql: FATAL: Ident authentication failed for user "skylendar"
              > >
              > > Icons? Overrated! :)
              > >
              > > But you don't mention skygrant. You don't need to run it?
              >
              > No I don't.
              >
              > > And, thanks! I do very much appreciate it :)
              > >
              >
              > Apparently, your psql users need a password.
              > There is a very usefull command under linux: "man".
              > So: "man man", "man createuser", "man createdb", "man createlang"...
              > www.postgresql.org has comprehensive documentation about relational
              > database.
              >
              Thanks, I will read the relational database part in the documentation.
              I'm working with a blindfold here, so it helps me a lot when I know
              what to look for.
              And the man command also was a giant step forward. Sorry for bothering
              with newbee questions.
              :)
            • skylendar
              ... the linux ... postgres ... superuser ... Groups ... is not ... the same ... and skylendar= ... Owner:skylendar, ... 8) :) ... psql -f
              Message 6 of 9 , Nov 30, 2007
              • 0 Attachment
                --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@...> wrote:
                >
                > --- In skylendar@yahoogroups.com, "stnsls" <stnsls@> wrote:
                > >
                > > --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@> wrote:
                > >
                > > > 4)&5) Er ... cough... This is maybe where I should return to
                the linux
                > > > newbee forum for a discussion about the differences between a
                postgres
                > > > user and a system user... (?)
                > > > After "su postgres" I did a "createuser skylendar" with the
                superuser
                > > > flag. This user is reported as a system user in the Users and
                Groups
                > > > utility. It also has it's own home folder /home/skylendar. This
                is not
                > > > good enough?
                > > >
                > > > 6) I have created the database. Used -E UNICODE, but it gave
                the same
                > > > result. When I "su skylendar", "psql -U skylendar"
                and "skylendar=>
                > > > \l", one of the databases listed are Name:skylendar,
                Owner:skylendar,
                > > > Coding:UTF8
                > > >
                > > >
                8) :) ... "psql -f /usr/src/skylendar-1.7.0/src/installskydb.sql -U
                > > > skylendar -d skylendar" worked - a bit...
                > > > It generated a long output, but then it ended with:
                > > > psql:/usr/src/skylendar-1.7.0/src/installskydb.sql:510:
                \connect
                > > > FATAL: Ident authentication failed for user "postgres"
                > > > I tried to "su postgres" and run the same command, but it just
                said:
                > > > psql: FATAL: Ident authentication failed for user "skylendar"
                > > >
                > > > Icons? Overrated! :)
                > > >
                > > > But you don't mention skygrant. You don't need to run it?
                > >
                > > No I don't.
                > >
                > > > And, thanks! I do very much appreciate it :)
                > > >
                > >
                > > Apparently, your psql users need a password.
                > > There is a very usefull command under linux: "man".
                > > So: "man man", "man createuser", "man createdb", "man
                createlang"...
                > > www.postgresql.org has comprehensive documentation about
                relational
                > > database.
                > >
                > Thanks, I will read the relational database part in the
                documentation.
                > I'm working with a blindfold here, so it helps me a lot when I know
                > what to look for.
                > And the man command also was a giant step forward. Sorry for
                bothering
                > with newbee questions.
                > :)
                >

                Of course you need to run skygrant. Grants on db tables are
                attributed to a users group, not to an individual.
                If you are still introuble, reload the sources from my site and
                reread carefully the installation process.
              • gjerte
                ... Ok, but from where/as whom do I run skygrant? I am still in trouble, and have done as you said – downloaded Skygrant and tar ed it. The only installation
                Message 7 of 9 , Nov 30, 2007
                • 0 Attachment
                  > Of course you need to run skygrant. Grants on db tables are
                  > attributed to a users group, not to an individual.
                  > If you are still introuble, reload the sources from my site and
                  > reread carefully the installation process.
                  >

                  Ok, but from where/as whom do I run skygrant?

                  I am still in trouble, and have done as you said – downloaded
                  Skygrant and tar'ed it. The only installation instruction I can find
                  there is INSTALL, and I seem to have got past the point which it
                  describes. I also was very accurate in following the installation
                  instructions given on the website.
                  I have not gone linuxnewbeeforum with this yet because skygrant and
                  installskydb is Skylendar specific commands – but please tell me if I
                  should.

                  As far as I understand I somehow need to give installskydb access to
                  the postgres user. And I guess this is not the same as running
                  skygrant, who gives system users access to the skylendar database (?)
                  What bothers me is that, still as far as I understand, the access to
                  postgres should be default since I'm running installskydb as
                  postgresql user skylendar – who has been given superuser rights.

                  Now, I would still love to RTFM, but it is also a bit overwhelming. I
                  am using man (command)" on any command I do now, and I learn a lot
                  from that.
                  The "relational database", however, seems to be the wrong track. As
                  far as I understand it is a (somewhat inaccurate) description of how
                  a postgresql database is built up, and not, as I thought, a hint on
                  what FM to read on how to make installskydb able to access the
                  postgres user when run from postgresql user skylendar.
                  Any other hint on what to read would be welcomed and very much
                  appreciated.

                  Just to make sure I've got this right I have done these steps:
                  Deleted the postgresql database skylendar, user skylendar, and system
                  user skylendar.
                  Deleted /home/skylendar.
                  Rebooted and created a system user skylendar.
                  Rebooted and logged in as system user skylendar.
                  Opened a root console and "su postgres", then "createuser –s –d –r
                  skylendar", then "createdb skylendar –O skylendar –E utf8"
                  Checked procedural language with "createlang –l skylendar" – output
                  says plpgsql.
                  Then, still as postgres, executed "psql –f /usr/src/skylendar-
                  1.7.0/src/installskydb.sql –U skylendar -d skylendar" – output says:
                  psql: FATAL: Ident authentication failed for user "skylendar"
                  Did "su skylendar", then "psql –f /usr/src/skylendar-
                  1.7.0/src/installskydb.sql –U skylendar -d skylendar" – Same result
                  as in previous post, long output who ends with:
                  psql:/usr/src/skylendar-1.7.0/src/installskydb.sql:510: \connect
                  FATAL: Ident authentication failed for user "postgres"

                  Thanks :)
                • skylendar
                  ... user, ... language. ... Skylendar-specific ... with ... think ... found ! ... Normally, skygrant checks if the shell variable $UID = 0. Open a text
                  Message 8 of 9 , Dec 1, 2007
                  • 0 Attachment
                    --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@...> wrote:
                    >
                    > Ok, I have it installed now - system user skylendar, postgres
                    user,
                    > database (also skylendar) with unicode (UTF-8) and plpgsql
                    language.
                    > Have two questions, though, and I think they are
                    Skylendar-specific
                    > enough to ask. If you think I should RTFM it would be very nice
                    with
                    > a hint on what manual.
                    >
                    > From where do I run skygrant?
                    > I have tried to run it as root, superuser and whatever I could
                    think
                    > of, but I get the same message "/usr/bin/skygrant must be executed
                    > as root !"
                    >
                    > I cant run installskydb either. I have modified the script as
                    > suggested in the forum, but it still gives "pg_hba.conf not
                    found !"
                    > It would be really nice if you could have a look, heres the
                    > modificated part with the correct path:
                    >
                    >
                    > elif [ -w /etc/postgresql/8.1/main/pg_hba.conf ]; then
                    > export PGDATA=/etc/postgresql/8.1/main
                    >
                    > Thanks :)
                    >

                    Normally, skygrant checks if the shell variable $UID = 0. Open a
                    text console, login as root and do a: echo $UID . You'll see whether
                    it's correct or not.

                    As to installskydb. Get installskydb from the latest skylendar
                    sources, and run: installskydb /etc/postgresql/8.1/main

                    I can't ensure a seamless installation process for all the distros.
                    Some users have maybe successfully installed sk for your distro, but
                    they won't help neither of us. So...

                    Regards,

                    C.
                  • gjerte
                    ... echo $UID returns 0 I downloaded the source again. Replaced the installskydb files with the new (they appear to be the same as the ones I used), and got
                    Message 9 of 9 , Dec 2, 2007
                    • 0 Attachment
                      --- In skylendar@yahoogroups.com, "skylendar" <skylendar@...> wrote:
                      >
                      > --- In skylendar@yahoogroups.com, "gjerte" <djevelunge@> wrote:
                      > >
                      > > Ok, I have it installed now - system user skylendar, postgres
                      > user,
                      > > database (also skylendar) with unicode (UTF-8) and plpgsql
                      > language.
                      > > Have two questions, though, and I think they are
                      > Skylendar-specific
                      > > enough to ask. If you think I should RTFM it would be very nice
                      > with
                      > > a hint on what manual.
                      > >
                      > > From where do I run skygrant?
                      > > I have tried to run it as root, superuser and whatever I could
                      > think
                      > > of, but I get the same message "/usr/bin/skygrant must be executed
                      > > as root !"
                      > >
                      > > I cant run installskydb either. I have modified the script as
                      > > suggested in the forum, but it still gives "pg_hba.conf not
                      > found !"
                      > > It would be really nice if you could have a look, heres the
                      > > modificated part with the correct path:
                      > >
                      > >
                      > > elif [ -w /etc/postgresql/8.1/main/pg_hba.conf ]; then
                      > > export PGDATA=/etc/postgresql/8.1/main
                      > >
                      > > Thanks :)
                      > >
                      >
                      > Normally, skygrant checks if the shell variable $UID = 0. Open a
                      > text console, login as root and do a: echo $UID . You'll see whether
                      > it's correct or not.
                      >
                      > As to installskydb. Get installskydb from the latest skylendar
                      > sources, and run: installskydb /etc/postgresql/8.1/main
                      >
                      > I can't ensure a seamless installation process for all the distros.
                      > Some users have maybe successfully installed sk for your distro, but
                      > they won't help neither of us. So...
                      >
                      > Regards,
                      >
                      > C.
                      >
                      "echo $UID" returns 0

                      I downloaded the source again. Replaced the installskydb files with
                      the new (they appear to be the same as the ones I used), and got the
                      same result.
                      I draw the conclusion that installing on Debian is above my capabilities.

                      Downloaded Mandriva 2008. It spends one and a half hour starting up
                      before the pc dies. Older versions of Debian had the problem of not
                      being able to run the fan on old Armada laptops - this may be case for
                      Mandriva to. At least it has the apperance of a termal safety shutdown.

                      The PCLinux, however seems to work fine. Which leads me to the
                      temptation of trying an install of MiniME. It would be great if I
                      could save some space on the 4 gig HD.

                      Thank you for your help.
                      Hail Eris.
                      :)
                    Your message has been successfully submitted and would be delivered to recipients shortly.